Bug 208650 - ThinkPad resumes from Suspend with a blank screen, not usable at all
ThinkPad resumes from Suspend with a blank screen, not usable at all
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
http://thinkwiki.org/wiki/Problem_wit...
:
Depends On: 188413
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 17:07 EDT by Zack Cerza
Modified: 2015-03-04 20:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 10:57:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2006-09-29 17:07:12 EDT
+++ This bug was initially created as a clone of Bug #188413 +++

Description of problem:
This is a Thinkpad specific issue where subjected Thinkpad and few other models
are not able to resume from suspend in a useful state without workarounds. The
clear problem is that dispaly remains in a blank state while the input is
working via keyboard.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.14.0-1

How reproducible:
After every suspend to RAM, upon resume 

Steps to Reproduce:
1. Click "System" -> "Suspend"
2. After System has suspended, resume from the power button

  
Actual results:
System resumes from suspend state but the diplay is in a blank state and is not
useful at all.

Expected results:
Fully functional system resume from the suspended state

Additional info:
I am testing the same on a Think Pad R50e with intel 82852/855GM chipset.
http://thinkwiki.org/wiki/Problem_with_display_remaining_black_after_resume#Solution_for_ThinkPads_with_Intel_Extreme_Graphics_2

-- Additional comment from richard@hughsie.com on 2006-04-09 08:31 EST --
I think this bug should more correctly be assigned to pm-utils, as it requires a
resume action similar to what we do with intel and ati cards.


-- Additional comment from richard@hughsie.com on 2006-06-20 18:34 EST --
You might want to see http://hughsient.livejournal.com/1906.html
Comment 1 Zack Cerza 2006-09-29 17:08:43 EDT
Awesomely simple fix: remove the VBE post in /etc/pm/functions-intel.
Comment 2 Richard Hughes 2006-09-29 18:10:38 EDT
Or ship the newer pm-utils and my hal patch to automate this.
Comment 3 Matthew Miller 2007-04-06 15:07:27 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 Valent Turkovic 2007-05-02 11:55:09 EDT
I just want to say that I have also this issue with Fedora Core 6 with latest
updates. My laptop is IBM Thinkpad R52

Please fix this in Fedora Core 6 and in Fedora 7.

Thank you.

ps. If you need someone for testing I'm willing to volunteer my time.
Comment 6 Valent Turkovic 2007-05-21 16:57:34 EDT
I found a fix for my IBM R52 laptop:
http://thinkwiki.org/wiki/Problem_with_display_remaining_black_after_resume#Solution_for_ThinkPads_with_ATI_graphic_chips_and_Intel_915.2F945GM

you need to edit /boot/grub/menu.lst and add "acpi_sleep=s3_bios" at the end of
kernel line.

comment #1 doesn't work with IBM R52 with Intel graphics!

Please make this work by default on Fedora 7.

Thank you.
Comment 7 Richard Hughes 2007-05-22 10:19:58 EDT
Please see http://people.freedesktop.org/~hughsient/temp/quirk/quirk-intro.html
Comment 8 Valent Turkovic 2007-05-23 10:38:26 EDT
quirk guide isn't too helpful because I tried using it to fix my other laptop:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=240964
and it didn't get me far! :(
Comment 9 Zack Cerza 2007-05-23 12:03:07 EDT
So? It's different hardware...
Comment 10 Nigel Cunningham 2007-12-10 17:47:29 EST
Is this now fixed with Fedora 7 updates or Fedora 8?
Comment 11 Valent Turkovic 2007-12-19 17:34:29 EST
Yes
Comment 12 Zack Cerza 2007-12-20 10:57:24 EST
Forgot this was still open. Closing.

Note You need to log in before you can comment on or make changes to this bug.