Bug 2087 - won't install
won't install
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
Depends On:
  Show dependency treegraph
Reported: 1999-04-09 11:41 EDT by nmace85
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-04-14 13:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description nmace85 1999-04-09 11:41:36 EDT
i just purchased RH 5.2, i had just totally messed up my RH
5.1 installation, so i was going to format it and install
5.2.  the problem is that when i select "Workstation" it
says that i don't have enough room.  but i have over 2 gigs
of free space.  i have tried it with the free scape
partitioned, and as it just free space with the same result
both times.  the custom install works just fine, except that
i HATE hand-seleting the packages. has anyone else reported
this problem?  i have tried on my computer and a friends as
well.  it did the same thing on his.  can someone tell me
what i need to do fix it?
Comment 1 Michael K. Johnson 1999-04-09 20:28:59 EDT
It may be looking for free space in known-bootable area.
The automated installs have to be ultra-conservative in
this area or else we'll install lots of machines into a
non-bootable state and people won't be happy with that,

If you could post here a listing from fdisk of all the drives
in the system (I presume when you  say that 2G is free you mean
that some other OS is taking some of the room on the disk) that
would help us be able to tell more accurately whether the install
is just being conservative because it is unsure that it can install
a bootable system, or if there is a genuine bug here.

Thanks for taking the trouble to file the bug report.

------- Email Received From  "Nathan Mace" <nmace85@hotmail.com> 04/09/99 21:24 -------
Comment 2 nmace85 1999-04-09 21:24:59 EDT
i have a 6.4 gig hard drive(total)  i ahve a primary dos partition
that takes up 2 gigs.  i have an extended dos partition with a logical
drive inside that takes up 2 gig.  then the remaining space was just
"there" free and unpartitioned.  i also tried partitioning it to and i
got the same error
Comment 3 Michael K. Johnson 1999-04-14 13:51:59 EDT
OK, my conjecture was correct: with a 2GB partition at the beginning
of the disk, the install cannot be sure that Linux will be bootable,
as on many machines, only the first 1GB is directly bootable.  This
is a feature, not a bug.  It is unfortunate that it makes your life
harder; it would, however, cause even more trouble if we changed it.

I'm sorry I can't provide you with a more favorable answer.

(In response to your emailed question: emailing and posting to the
web page both work; both are available to us from the web interface.)

Note You need to log in before you can comment on or make changes to this bug.