Bug 2087066 - mokutil -s aborts without error message
Summary: mokutil -s aborts without error message
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mokutil
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2090441 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-17 08:49 UTC by Oliver Steffen
Modified: 2022-06-01 01:25 UTC (History)
4 users (show)

Fixed In Version: mokutil-0.6.0-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-23 18:44:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Oliver Steffen 2022-05-17 08:49:04 UTC
Description of problem:
mokutil exits with "Aborted (core dumped)" when running with "-s" as argument:

# mokutil -s

This is not critical, but confusing.

Version-Release number of selected component (if applicable):
mokutil-0.6.0-1.fc36.x86_64

How reproducible:
100%

Steps to Reproduce:
1. run mokutil -s

Actual results:
mokutil aborts

Expected results:
The help message is displayed, because "-s" is not a valid command line argument.

Additional info:
The same seems to happen for all arguments starting with "-s":

[root@osteffen-laptop osteffen]# mokutil -s
Aborted (core dumped)
[root@osteffen-laptop osteffen]# mokutil -sa
Aborted (core dumped)
[root@osteffen-laptop osteffen]# mokutil -sAAAAA
Aborted (core dumped)
[root@osteffen-laptop osteffen]# mokutil -sAAAAAassdgfassdfg
Aborted (core dumped)
[root@osteffen-laptop osteffen]# mokutil -sb-state
Aborted (core dumped)


Hint:
The abort happens in src/mokutil.c:2093

Comment 1 Robbie Harwood 2022-05-17 15:25:39 UTC
It's an intentional abort.  I'm not sure why mokutil chose to do this, but I sent a PR, so let's find out: https://github.com/lcp/mokutil/pull/53

Comment 2 Fedora Update System 2022-05-23 20:36:04 UTC
FEDORA-2022-dddf406d7f has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-dddf406d7f

Comment 3 Fedora Update System 2022-05-23 20:36:06 UTC
FEDORA-2022-e4be550a47 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-e4be550a47

Comment 4 Fedora Update System 2022-05-24 01:13:53 UTC
FEDORA-2022-e4be550a47 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-e4be550a47`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-e4be550a47

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-05-24 01:15:54 UTC
FEDORA-2022-dddf406d7f has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-dddf406d7f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-dddf406d7f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Geraldo Simião 2022-05-25 18:26:14 UTC
(In reply to Fedora Update System from comment #3)
> FEDORA-2022-e4be550a47 has been submitted as an update to Fedora 36.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-e4be550a47

Bug still present

rpm -qa|grep mokutil ==> mokutil-0.6.0-2.fc36.x86_64
mokutil --sb-state ==> SecureBoot disabled
mokutil -s ==> Abortado (imagem do núcleo gravada)

       coredumpctl info
       PID: 6979 (mokutil)
       UID: 1000 (geraldo)
       GID: 1000 (geraldo)
       Signal: 6 (ABRT)
       Timestamp: Wed 2022-05-25 15:17:48 -03 (56s ago)
       Command Line: mokutil -s
       Executable: /usr/bin/mokutil
       Control Group: /user.slice/user-1000.slice/user@1000.service/app.slice/app-org.kde.konsole-cc4451fdcc194b2e98e5b50fe77f9a23.scope
       Unit: user@1000.service
       User Unit: app-org.kde.konsole-cc4451fdcc194b2e98e5b50fe77f9a23.scope
       Slice: user-1000.slice
       Owner UID: 1000 (geraldo)
         Storage: /var/lib/systemd/coredump/core.mokutil.1000.613f9a483d494871ad63650de27d7ad0.6979.1653502668000000.zst (present)
         Disk Size: 78.9K

Comment 7 Geraldo Simião 2022-05-25 18:43:55 UTC
*** Bug 2090441 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2022-05-26 02:32:02 UTC
FEDORA-2022-e4be550a47 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-e4be550a47`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-e4be550a47

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-05-26 02:33:20 UTC
FEDORA-2022-dddf406d7f has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-dddf406d7f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-dddf406d7f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Geraldo Simião 2022-05-26 13:01:36 UTC
(In reply to Fedora Update System from comment #8)
> FEDORA-2022-e4be550a47 has been pushed to the Fedora 36 testing repository.


This update fixed the bug. No more errors.

Comment 11 Fedora Update System 2022-06-01 01:24:07 UTC
FEDORA-2022-e4be550a47 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2022-06-01 01:25:58 UTC
FEDORA-2022-dddf406d7f has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.