Bug 208711 - FC6 latest xorg rpms cause X not to display
FC6 latest xorg rpms cause X not to display
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-30 12:57 EDT by Dave Russell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-22 13:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (61.24 KB, text/plain)
2006-09-30 12:57 EDT, Dave Russell
no flags Details
xorg.conf (594 bytes, text/plain)
2006-09-30 12:58 EDT, Dave Russell
no flags Details
xorg.0.log showing a lack of display (59.32 KB, text/plain)
2006-10-06 10:15 EDT, Dave Russell
no flags Details
xorg log file when the driver is set to vesa (56.27 KB, text/plain)
2006-10-06 10:45 EDT, Dave Russell
no flags Details

  None (edit)
Description Dave Russell 2006-09-30 12:57:36 EDT
Description of problem:
No X display at all!

I recently updated my (previously working) FC5-T3 machine to the latest xorg
rpms and now when X is supposed to start, there is a brief flash and a few block
appear on the screen before my tft goes into powersave mode (no signal).

Version-Release number of selected component (if applicable):

xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-drv-nsc-2.8.1-2.1
xorg-x11-drv-aiptek-1.0.1-2
xorg-x11-drv-glint-1.1.1-4.1
xorg-x11-drv-cyrix-1.1.0-4
xorg-x11-drv-v4l-0.1.1-4
xorg-x11-drv-digitaledge-1.1.0-1.1
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-fonts-truetype-7.1-2
xorg-x11-drv-sis-0.9.1-6
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-xauth-1.0.1-2.1
xorg-x11-utils-7.1-2.fc6
xorg-x11-apps-7.1-2.fc6
xorg-x11-drv-magellan-1.1.0-1.1
xorg-x11-drv-hyperpen-1.1.0-2
xorg-x11-drv-calcomp-1.1.0-1.1
xorg-x11-drv-elo2300-1.1.0-1.1
xorg-x11-drv-penmount-1.1.0-2.1
xorg-x11-drv-ark-0.6.0-2.1
xorg-x11-drv-fbdev-0.3.0-2
xorg-x11-fonts-100dpi-7.1-2
xorg-x11-drv-via-0.2.1-5
xorg-x11-drv-trident-1.2.1-3.fc6
xorg-x11-drv-i740-1.1.0-2.1
xorg-x11-drv-dummy-0.2.0-2.1
xorg-x11-drv-ur98-1.1.0-1.1
xorg-x11-drv-magictouch-1.0.0.5-2.1
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2
xorg-x11-xinit-1.0.2-11.fc6
xorg-x11-twm-1.0.1-3.1
xorg-x11-drv-ast-0.81.0-3
xorg-x11-drv-mutouch-1.1.0-2
xorg-x11-drv-vga-4.1.0-2.1
xorg-x11-drv-voodoo-1.1.0-3.1
xorg-x11-drv-vmware-10.13.0-2.1
xorg-x11-drv-tseng-1.1.0-3.1
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-drv-fpit-1.1.0-1.1
xorg-x11-drv-sisusb-0.8.1-4.1
xorg-x11-drv-dmc-1.1.0-2
xorg-x11-drv-dynapro-1.1.0-2
xorg-x11-drv-apm-1.1.1-2.1
xorg-x11-fonts-base-7.1-2
xorg-x11-drv-nv-1.2.0-4.fc6
xorg-x11-drv-cirrus-1.1.0-2.fc6
xorg-x11-fonts-Type1-7.1-2
xorg-x11-fonts-misc-7.1-2
xorg-x11-xdm-1.0.5-5.fc6
xorg-x11-server-Xorg-1.1.1-43.fc6
xorg-x11-drv-evdev-1.1.2-2.1
xorg-x11-drv-elographics-1.1.0-1.1
xorg-x11-drv-joystick-1.1.0-1.1
xorg-x11-drv-neomagic-1.1.1-2.1
xorg-x11-drv-citron-2.2.0-1.1
xorg-x11-drv-siliconmotion-1.4.1-2.1
xorg-x11-drv-palmax-1.1.0-1.1
xorg-x11-drv-acecad-1.1.0-2.1
xorg-x11-drivers-7.1-3
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2
xorg-x11-drv-i810-1.6.5-8.fc6
xorg-x11-drv-mouse-1.1.1-1.1
xorg-x11-drv-void-1.1.0-3.1
xorg-x11-drv-keyboard-1.1.0-2.1
xorg-x11-drv-rendition-4.1.0-3.1
xorg-x11-drv-jamstudio-1.1.0-1.1
xorg-x11-drv-chips-1.1.1-2.1
xorg-x11-drv-spaceorb-1.1.0-1.1
xorg-x11-drv-tdfx-1.2.1-3.1
xorg-x11-drv-i128-1.2.0-4
xorg-x11-proto-devel-7.1-8.fc6
xorg-x11-drv-ati-6.6.2-2.fc6
xorg-x11-font-utils-7.1-2
xorg-x11-xfs-1.0.2-3.1
xorg-x11-drv-microtouch-1.1.0-1.1
xorg-x11-drv-s3-0.4.1-2.1
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-s3virge-1.9.1-2.1
xorg-x11-drv-summa-1.1.0-1.1
xorg-x11-drv-mga-1.4.1-5.fc6
xorg-x11-fonts-75dpi-7.1-2
xorg-x11-drv-vesa-1.2.1-3


How reproducible:
Can't get an X display at all.

Steps to Reproduce:
1. Install FC5-T3
2. Upgrade to versions of rpms shown above
3. Get no X!
  
Actual results:
No X display

Expected results:
X display

Additional info:
Comment 1 Dave Russell 2006-09-30 12:57:36 EDT
Created attachment 137480 [details]
xorg log file
Comment 2 Dave Russell 2006-09-30 12:58:29 EDT
Created attachment 137481 [details]
xorg.conf
Comment 3 Dave Russell 2006-09-30 13:06:11 EDT
Quick observation... the last line in the xorg log file is this:

(**) RADEON(0): RADEONSaveScreen(2)

One might think this suggests that the card is going into powersave mode on its
own?? Random guess on my part.
Comment 4 Dave Russell 2006-10-02 14:42:00 EDT
Some recent updates via yum today caused me to retry...

I notice now that the machine now locks up hard when X starts, no ssh or network
access.

Current xorg rpm versions shown below

[root@luggage ~]# rpm -qa | grep xorg
xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-drv-nsc-2.8.1-2.1
xorg-x11-drv-aiptek-1.0.1-2
xorg-x11-drv-glint-1.1.1-4.1
xorg-x11-drv-cyrix-1.1.0-4
xorg-x11-drv-v4l-0.1.1-4
xorg-x11-drv-digitaledge-1.1.0-1.1
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-fonts-truetype-7.1-2
xorg-x11-xinit-1.0.2-12.fc6
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-xauth-1.0.1-2.1
xorg-x11-utils-7.1-2.fc6
xorg-x11-apps-7.1-2.fc6
xorg-x11-drv-magellan-1.1.0-1.1
xorg-x11-drv-hyperpen-1.1.0-2
xorg-x11-drv-calcomp-1.1.0-1.1
xorg-x11-drv-elo2300-1.1.0-1.1
xorg-x11-drv-penmount-1.1.0-2.1
xorg-x11-drv-ark-0.6.0-2.1
xorg-x11-drv-fbdev-0.3.0-2
xorg-x11-fonts-100dpi-7.1-2
xorg-x11-drv-via-0.2.1-5
xorg-x11-drv-i810-1.6.5-9.fc6
xorg-x11-drv-trident-1.2.1-3.fc6
xorg-x11-drv-i740-1.1.0-2.1
xorg-x11-drv-dummy-0.2.0-2.1
xorg-x11-drv-ur98-1.1.0-1.1
xorg-x11-drv-magictouch-1.0.0.5-2.1
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2
xorg-x11-proto-devel-7.1-9.fc6
xorg-x11-twm-1.0.1-3.1
xorg-x11-drv-ast-0.81.0-3
xorg-x11-drv-mutouch-1.1.0-2
xorg-x11-drv-vga-4.1.0-2.1
xorg-x11-drv-voodoo-1.1.0-3.1
xorg-x11-drv-vmware-10.13.0-2.1
xorg-x11-drv-tseng-1.1.0-3.1
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-drv-fpit-1.1.0-1.1
xorg-x11-drv-sisusb-0.8.1-4.1
xorg-x11-drv-dmc-1.1.0-2
xorg-x11-drv-dynapro-1.1.0-2
xorg-x11-drv-apm-1.1.1-2.1
xorg-x11-fonts-base-7.1-2
xorg-x11-drv-nv-1.2.0-4.fc6
xorg-x11-drv-cirrus-1.1.0-2.fc6
xorg-x11-fonts-Type1-7.1-2
xorg-x11-fonts-misc-7.1-2
xorg-x11-xdm-1.0.5-5.fc6
xorg-x11-server-Xorg-1.1.1-43.fc6
xorg-x11-drv-vesa-1.2.1-4
xorg-x11-drv-ati-6.6.2-3.fc6
xorg-x11-drv-evdev-1.1.2-2.1
xorg-x11-drv-elographics-1.1.0-1.1
xorg-x11-drv-joystick-1.1.0-1.1
xorg-x11-drv-neomagic-1.1.1-2.1
xorg-x11-drv-citron-2.2.0-1.1
xorg-x11-drv-siliconmotion-1.4.1-2.1
xorg-x11-drv-palmax-1.1.0-1.1
xorg-x11-drv-acecad-1.1.0-2.1
xorg-x11-drivers-7.1-3
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2
xorg-x11-drv-mouse-1.1.1-1.1
xorg-x11-drv-void-1.1.0-3.1
xorg-x11-drv-keyboard-1.1.0-2.1
xorg-x11-drv-rendition-4.1.0-3.1
xorg-x11-drv-jamstudio-1.1.0-1.1
xorg-x11-drv-chips-1.1.1-2.1
xorg-x11-drv-spaceorb-1.1.0-1.1
xorg-x11-drv-tdfx-1.2.1-3.1
xorg-x11-drv-i128-1.2.0-4
xorg-x11-font-utils-7.1-2
xorg-x11-xfs-1.0.2-3.1
xorg-x11-drv-microtouch-1.1.0-1.1
xorg-x11-drv-s3-0.4.1-2.1
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-s3virge-1.9.1-2.1
xorg-x11-drv-summa-1.1.0-1.1
xorg-x11-drv-mga-1.4.1-5.fc6
xorg-x11-fonts-75dpi-7.1-2
xorg-x11-drv-sis-0.9.1-7
Comment 5 Dave Russell 2006-10-03 02:00:22 EDT
top - 06:56:19 up 4 min,  1 user,  load average: 1.31, 0.73, 0.30
Tasks:  72 total,   3 running,  69 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.0%us,100.0%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   1292948k total,   359040k used,   933908k free,    22224k buffers
Swap:  2031608k total,        0k used,  2031608k free,   278036k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 2591 root      25   0  283m 4684 3624 R 99.7  0.4   2:39.48 Xorg
    1 root      15   0  2028  660  560 S  0.0  0.1   0:01.47 init

As you can see from this top listing, xorg is running at almost 100% cpu.

No wonder it's not starting up.

At least machine is no longer locking up hard (recent kernel update to
2.6.18-1.2724.fc6)
Comment 6 Adam Jackson 2006-10-03 10:38:49 EDT
What's Xorg doing when that happens?  (yum install xorg-x11-server-debuginfo,
su, gdb `pidof Xorg`, bt)
Comment 7 Adam Jackson 2006-10-03 10:56:50 EDT
sorry, gdb `which Xorg` `pidof Xorg`.
Comment 8 Dave Russell 2006-10-03 11:32:16 EDT
Hmm, I gdb'd and strace'd xorg after installing the debuginfo server, and I was
unable to get anything sensible.

Following a reboot (init 3, init 5 was not sufficient)... X came up fine.

Not quite sure what to make of that.
Comment 9 Dave Russell 2006-10-03 11:45:41 EDT
Tried removing the debuginfo rpm, and restarted X, machine locks hard instead of
starting X.

Machine is remote, so will have to get someone to power cycle it later today.
Comment 10 Adam Jackson 2006-10-03 11:52:05 EDT
If it's hanging, boot it into runlevel 1 and scp the log file off.  There's
probably some spew at the end that's informative.
Comment 11 Dave Russell 2006-10-03 12:00:49 EDT
Will give that a shot, it boots by default into runlevel 3, so I should be able
to get the log off once it's been powercycled.

Thanks.
Comment 12 Dave Russell 2006-10-06 04:59:30 EDT
Well today being another day I thought I'd give this another try, however
following the latest updates my machine seems to have no boot sector...

Oh dear.
Comment 13 Dave Russell 2006-10-06 09:53:23 EDT
OK fresh install from rawhide (not sure what killed the last install, and since
no important data, re-install was faster), the problem is still there.

xorg sits there at 100% cpu usage, no display shown.

Should also note that firstboot works fine, as does the display all through the
installation.

I'm installing the debuginfo package for xorg to see if I can find out what it's
doing (as suggested).

Following a fresh reinstall and update I have the following rpms/versions installed:

[root@luggage ~]# rpm -qa | grep -i xorg
xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-xauth-1.0.1-2.1
xorg-x11-xinit-1.0.2-12.fc6
xorg-x11-apps-7.1-3.fc6
xorg-x11-fonts-base-7.1-2
xorg-x11-fonts-misc-7.1-2
xorg-x11-fonts-truetype-7.1-2
xorg-x11-drv-citron-2.2.0-1.1
xorg-x11-drv-palmax-1.1.0-1.1
xorg-x11-drv-vga-4.1.0-2.1
xorg-x11-drv-microtouch-1.1.0-1.1
xorg-x11-drv-via-0.2.1-7
xorg-x11-drv-spaceorb-1.1.0-1.1
xorg-x11-drv-v4l-0.1.1-4
xorg-x11-drv-vmware-10.13.0-2.1
xorg-x11-drv-apm-1.1.1-2.1
xorg-x11-drv-mutouch-1.1.0-2
xorg-x11-drv-dmc-1.1.0-2
xorg-x11-drv-dynapro-1.1.0-2
xorg-x11-drv-jamstudio-1.1.0-1.1
xorg-x11-drv-dummy-0.2.0-2.1
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-font-utils-7.1-2
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-drv-vesa-1.2.1-4
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2
xorg-x11-fonts-Type1-7.1-2
xorg-x11-fonts-75dpi-7.1-2
xorg-x11-server-Xorg-1.1.1-47.fc6
xorg-x11-drv-keyboard-1.1.0-2.1
xorg-x11-drv-mga-1.4.1-5.fc6
xorg-x11-drv-penmount-1.1.0-2.1
xorg-x11-drv-elographics-1.1.0-1.1
xorg-x11-drv-nsc-2.8.1-2.1
xorg-x11-drv-s3-0.4.1-2.1
xorg-x11-drv-trident-1.2.1-3.fc6
xorg-x11-drv-summa-1.1.0-1.1
xorg-x11-drv-cirrus-1.1.0-2.fc6
xorg-x11-drv-hyperpen-1.1.0-2
xorg-x11-drv-ur98-1.1.0-1.1
xorg-x11-drv-sisusb-0.8.1-4.1
xorg-x11-drv-joystick-1.1.0-1.1
xorg-x11-drv-siliconmotion-1.4.1-2.1
xorg-x11-drv-i810-1.6.5-9.fc6
xorg-x11-drv-magellan-1.1.0-1.1
xorg-x11-drv-fbdev-0.3.0-2
xorg-x11-drv-i740-1.1.0-2.1
xorg-x11-drv-ast-0.81.0-3
xorg-x11-drv-tdfx-1.2.1-3.1
xorg-x11-drv-fpit-1.1.0-1.1
xorg-x11-drv-s3virge-1.9.1-2.1
xorg-x11-drv-ati-6.6.2-4.fc6
xorg-x11-drv-voodoo-1.1.0-3.1
xorg-x11-drv-elo2300-1.1.0-1.1
xorg-x11-drv-magictouch-1.0.0.5-2.1
xorg-x11-drv-cyrix-1.1.0-4
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-i128-1.2.0-4
xorg-x11-twm-1.0.1-3.1
xorg-x11-utils-7.1-2.fc6
xorg-x11-xfs-1.0.2-3.1
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2
xorg-x11-fonts-100dpi-7.1-2
xorg-x11-drv-evdev-1.1.2-2.1
xorg-x11-drv-void-1.1.0-3.1
xorg-x11-drv-mouse-1.1.1-1.1
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-drv-acecad-1.1.0-2.1
xorg-x11-drv-chips-1.1.1-2.1
xorg-x11-drv-neomagic-1.1.1-2.1
xorg-x11-drv-tseng-1.1.0-3.1
xorg-x11-drv-digitaledge-1.1.0-1.1
xorg-x11-drv-glint-1.1.1-4.1
xorg-x11-drv-ark-0.6.0-2.1
xorg-x11-drv-aiptek-1.0.1-2
xorg-x11-drv-rendition-4.1.0-3.1
xorg-x11-drv-calcomp-1.1.0-1.1
xorg-x11-drv-sis-0.9.1-7
xorg-x11-drv-nv-1.2.0-4.fc6
xorg-x11-drivers-7.1-3
Comment 14 Dave Russell 2006-10-06 10:07:24 EDT
Not looking good...

[root@luggage ~]# gdb `which Xorg` `pidof Xorg`
GNU gdb Red Hat Linux (6.5-8.fc6rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

Attaching to program: /usr/bin/Xorg, process 2550


This is all I get, it just seems to sit there.
Comment 15 Dave Russell 2006-10-06 10:11:58 EDT
Note that my monitor *does* think it's being sent a signal, 1600x1200 60hz (not
the 1920x1200 native resolution of my monitor) but I don't see anything displayed.

The monitor is not rejecting the signal, but the signal does appear to be blank!

Updated xorg.0.log to follow.
Comment 16 Dave Russell 2006-10-06 10:15:43 EDT
Created attachment 137921 [details]
xorg.0.log showing a lack of display
Comment 17 Dave Russell 2006-10-06 10:35:28 EDT
As soon as I attempt to change runlevels (init 3) or reboot, the machine locks hard.

It appears to be "stable" in the 99.1% busy state, but that stability must be
fragile.
Comment 18 Dave Russell 2006-10-06 10:44:36 EDT
Desperate measures... I replaced the radeon driver section with vesa, and
wouldn't you just know it... I get a display.

There was no wierdness at the end of the xorg.0.log after the machine locked up.

I've attached the vesa xorg.0.log below.
Comment 19 Dave Russell 2006-10-06 10:45:16 EDT
Created attachment 137922 [details]
xorg log file when the driver is set to vesa
Comment 20 Dave Russell 2006-10-08 15:11:58 EDT
Unfortunately not only is the vesa driver really slow (but better than no
display) but I can't get it to display the native resolution of my 1920x1200 TFT
monitor.

Probably a limitation of the vesa driver.

Please someone shed some light on this!
Comment 21 Dave Russell 2006-10-22 13:44:19 EDT
Well following a few weeks passing and many many updates, I've re-visited this.
Re-selecting radeon from the system-config-display menu, rebooting and then
selecting the correct display resolution and it's all working!

Note You need to log in before you can comment on or make changes to this bug.