Bug 2087117 - flatpak-builder fails with fuse: unknown option(s): `-o splice_write,splice_move'
Summary: flatpak-builder fails with fuse: unknown option(s): `-o splice_write,splice_m...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ostree
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonathan Lebon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-17 11:15 UTC by Kamil Páral
Modified: 2022-05-23 11:44 UTC (History)
10 users (show)

Fixed In Version: ostree-2022.3-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-22 01:18:10 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github flatpak flatpak-builder issues 448 0 None closed [Bug]: Fails to start rofiles-fuse from ostree >= 2022.1 if ostree was built against FUSE 3 2022-05-17 11:15:47 UTC

Description Kamil Páral 2022-05-17 11:15:33 UTC
Description of problem:
I wanted to update my Flathub project, but my local build failed:

$ flatpak-builder builddir org.freefilesync.FreeFileSync.yml --force-clean --ccache
Emptying app dir 'builddir'
Downloading sources
Fetching git repo https://github.com/jinfeihan57/p7zip.git, ref refs/tags/v17.04
remote: Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
Starting build of org.freefilesync.FreeFileSync
Cache hit for intltool, skipping build
Cache hit for gtk2, skipping build
Cache hit for ibus-gtk2, skipping build
Cache hit for gnome-themes-extra, skipping build
Cache hit for p7zip, skipping build
Cache miss, checking out last cache hit
fuse: unknown option(s): `-o splice_write,splice_move'
========================================================================
Building module freefilesync in /home/kparal/devel/flatpak/org.freefilesync.FreeFileSync/.flatpak-builder/build/freefilesync-2
========================================================================
Running: cp apply_extra /app/bin/
error: Build directory /home/kparal/devel/flatpak/org.freefilesync.FreeFileSync/.flatpak-builder/rofiles/rofiles-nnXdi2 not initialized, use flatpak build-init
Error: module freefilesync: Child process exited with code 1

This used to work perfectly in F35.

I found this bug related to the error message:
https://github.com/flatpak/flatpak-builder/issues/448

However, it should be fixed in flatpak-builder-1.2.2, which I have. Perhaps it needs to be recompiled with some options or something?

Version-Release number of selected component (if applicable):
flatpak-builder-1.2.2-2.fc36.x86_64
flatpak-1.12.7-2.fc36.x86_64
ostree-2022.3-2.fc36.x86_64
fuse-2.9.9-14.fc36.x86_64
fuse3-3.10.5-2.fc36.x86_64


How reproducible:
always, for me

Steps to Reproduce:
1. use flatpak-builder to build any project, probably

Comment 1 Debarshi Ray 2022-05-18 22:10:08 UTC
This is because someone over-zealously merged an ostree change that was strictly meant for Rawhide into Fedora 36 a few days before GA:
https://src.fedoraproject.org/rpms/ostree/pull-request/29

Re-assigning to ostree.

I think that the switch to FUSE 3 should be done only in Rawhide, so that we can shake out problems in other consumers of the rofiles-fuse binary.  Fedora 36 should be reverted to FUSE 2.

Comment 2 Debarshi Ray 2022-05-18 22:12:01 UTC
(In reply to Debarshi Ray from comment #1)
> I think that the switch to FUSE 3 should be done only in Rawhide, so that we
> can shake out problems in other consumers of the rofiles-fuse binary.

eg., there might be some fallout in GNOME Builder.

Comment 4 Fedora Update System 2022-05-19 16:11:22 UTC
FEDORA-2022-d9971c4e47 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d9971c4e47

Comment 5 Fedora Update System 2022-05-20 02:54:36 UTC
FEDORA-2022-d9971c4e47 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-d9971c4e47`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d9971c4e47

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-05-22 01:18:10 UTC
FEDORA-2022-d9971c4e47 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Kamil Páral 2022-05-23 11:44:55 UTC
Confirmed fixed, thanks.


Note You need to log in before you can comment on or make changes to this bug.