Bug 208717 - RFE: visual feedback during slow Dependency Check
RFE: visual feedback during slow Dependency Check
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-30 15:08 EDT by John Reiser
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 17:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2006-09-30 15:08:47 EDT
Description of problem: The Dependency Check phase of an install or upgrade,
during which the screen displays "Checking dependencies in packages selected for
installation", takes too long.  On a 1.25GHz machine (PowerPC Apple Macintosh
mini) with 512MB DDR RAM (and no swapping), it takes minutes for Base + Software
Development (approx. 900 packages.)  This is too long; it feels like the system
is hung in an infinite loop, particularly because there is no visual feedback.

If checking the dependencies cannot be sped up by a factor of 10, then please
provide a progress bar.  900 packages in 50 character positions ==> 18 packages
per character of progress.  This is suitable to pacify an impatient installer.


Version-Release number of selected component (if applicable):
anaconda-11.1.0.102-1

How reproducible:
always

Steps to Reproduce:
1. clean install; or, upgrade from FC5 to FC6Pre.
2.
3.
  
Actual results:
Dependency Check phase takes minutes with no feedback on progress.

Expected results:
Dependency check takes 20 seconds or less, else provides visual feedback on
progress.

Additional info:
The algorithm must be to blame somehow: 900 packages * 10 dependencies
(guesitmated average) per package / 200 seconds is only 45 dependencies checked
per second; on a machine with more than 1 billion cycles per second.
Comment 1 Jeremy Katz 2006-10-01 18:49:07 EDT
I'll try to profile this at the office tomorrow and see if there's any obvious
slow spots being hit.  Unfortunately, given where we are in the cycle, if not, I
don't know that there's much choice as to what to do :/
Comment 2 Andrew 2006-10-24 19:26:01 EDT
I thought it was frozen too.  It must have taken at least 20 minutes to get to
1% dependency check on a Compaq Deskprop Pentium 3 733MHz.   

Over the years, I have installed many versions of Fedora Core and some of other
distributions on slow hardware, and FC6 is the slowest yet.  About 90 minutes
later and I'm stuck on "Preparing transaction from installation source: 0%".

:-/
Comment 3 Andrew 2006-10-25 14:24:39 EDT
I went back and measured carefully.  The dependency check took 24 minutes.  The
"Preparing transaction from" took only 23 minutes (after I added ide=nodma).  

Now I stuck on "Package Installation."  From 0 to 6 packages took 15 minutes,
and after 1 hour 37 minutes (from 0 packages), I'm still on package 6/793. 
Anaconda is running at maximum CPU, but there is some free memory.

(This is FC5->FC6 on a Pentium III 733MHz.)

Note You need to log in before you can comment on or make changes to this bug.