Bug 208728 - anaconda crashed selecting software development toggle
anaconda crashed selecting software development toggle
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-09-30 19:29 EDT by Tom Horsley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-01 19:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda backtrace saved to floppy (75.90 KB, text/plain)
2006-09-30 19:29 EDT, Tom Horsley
no flags Details
dump of anaconda failed installation (61.67 KB, text/plain)
2006-10-01 02:35 EDT, Scott Talbot
no flags Details

  None (edit)
Description Tom Horsley 2006-09-30 19:29:02 EDT
Description of problem:

I just installed from the fc6 prelease x86_64 DVD. I made it through
most of the screens OK, but then when I got to the initial package
selection page, the "Office apps" group is already checked by default,
and I tried to check the "Software Development" group just below it
(though it is possible I missed and the mouse was outside the check
box - I was just getting ready to look closer to see if I had hit
the box when I got the anaconda crash popup).

Version-Release number of selected component (if applicable):

whatever is on the prerelease DVD from the torrent.

How reproducible:

Only tried it once. I went directly to the "customize package selection"
button on my 2nd try, and that seemed to work OK. Got installed with no
more anaconda crashes.

Steps to Reproduce:
1. install x86_64 prelease fc6 from DVD
2. try to click on "Software Development" toggle in initial package page.
3. see crash popup
Actual results:


Expected results:

check box selected

Additional info:

On a possibly related note. I could swear I used to be able to right click
on a package group in the custom selection page and pick "select all optional
packages" and that would have the side effect of alaso selecting that
package group if it wasn't already selected. That didn't seem to work. If
the group wasn't selected, I had to first click the toggle to select it
before I could right click to select all optional (just part of the
"Let's keep making it harder and harder to just install everything"
philosophy I guess :-).
Comment 1 Tom Horsley 2006-09-30 19:29:02 EDT
Created attachment 137490 [details]
anaconda backtrace saved to floppy
Comment 2 Tom Horsley 2006-09-30 19:34:48 EDT
Just glancing at the anaconda trace I see it talking about IP stuff, not
package selection. I hope it didn't do something like fail to write the
new dump to the floppy and just leave the old one from my last crash with
static IP problems on the disk (I really did hear the disk going and see
the lights flash when I told it to save the dump to floppy though).
Comment 3 Scott Talbot 2006-10-01 02:35:56 EDT
Created attachment 137492 [details]
dump of anaconda failed installation
Comment 4 Scott Talbot 2006-10-01 02:42:21 EDT
I have similar experience as Mr Horsley, though I have i386 w/ realtek eth0 and
error also occurs after trying to add extras repository.
Comment 5 Jeremy Katz 2006-10-01 18:50:04 EDT
Can you try with the updates.img that was referenced in the release announcement?
Comment 6 Tom Horsley 2006-10-01 19:31:29 EDT
I just tried installer again with the updated image on a floppy and
my problem with clicking on "Software Development" seems to be fixed.
Just for grins, I tried going through initial installer again without
the updated, and once again it crashed when I clicked "Software Development",
so it does indeed seem to be fixed by the update.
Comment 7 Jeremy Katz 2006-10-01 19:38:46 EDT
Great, thanks for the quick verification!

Note You need to log in before you can comment on or make changes to this bug.