Bug 208731 - Remove directories for old versions of perl from @INC
Remove directories for old versions of perl from @INC
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
David Lawrence
:
: 205624 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-30 23:08 EDT by Robin Norwood
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 12:53:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Norwood 2006-09-30 23:08:23 EDT
From Jose on fedora-perl-devel-list:

   Removing support for perl 5.8.3 and perl 5.8.4 reduces the number
   of directories in the perl search path (@INC), which improves the
   perl modules loading time.

   This has already been done in past for FC-4 where support for
   perl 5.8.0/5.8.1/5.8.2 has dropped.

   perl specfile patch:
   --------------------
   --- perl.spec.588_8     2006-07-14 22:22:06.000000000 +0100
   +++ perl.spec   2006-09-17 16:10:58.000000000 +0100
   @@ -26,9 +26,7 @@
    Provides: perl(:WITHOUT_THREADS)
    %endif

   -%define perlmodcompat 5.8.7 5.8.6 5.8.5 5.8.4 5.8.3
   -Provides: perl(:MODULE_COMPAT_5.8.3)
   -Provides: perl(:MODULE_COMPAT_5.8.4)
   +%define perlmodcompat 5.8.7 5.8.6 5.8.5
    Provides: perl(:MODULE_COMPAT_5.8.5)
    Provides: perl(:MODULE_COMPAT_5.8.6)
    Provides: perl(:MODULE_COMPAT_5.8.7)
   --------------------

   Note:
   The FC-4 change was reported in the Release Notes.
Comment 1 Robin Norwood 2006-10-03 12:53:23 EDT
This is fixed in perl-5.8.8-10, which has been accepted for FC-6.
Comment 2 Chris Weyl 2006-10-03 13:13:44 EDT
This might be a bit untimely, but is this just to improve loading times, or is
there an actual incompatibility issue with modules built for 5.8.[34] and the
perl 5.8.8 package?
Comment 3 Robin Norwood 2006-10-03 13:24:25 EDT
Pretty much just for the loading time improvements.

It was discussed a bit on fedora-perl-devel-list:

https://www.redhat.com/archives/fedora-perl-devel-list/2006-September/msg00028.html

I discussed the issue a bit more offlist with Jose, and with Warren Togami, and
it was agreed that the best thing to do was to go ahead and drop the
directories.  That discussion should've been more open, I apologize...we didn't
mean to exclude anyone, I think fedora-perl-devel-list got dropped from the
recipients accidentally.

Do you anticipate any major problems with this change?
Comment 4 Robin Norwood 2006-10-17 16:14:23 EDT
*** Bug 205624 has been marked as a duplicate of this bug. ***
Comment 5 Chris Weyl 2006-10-27 20:15:18 EDT
On a belated note... :)  I don't anticipate any problems, but it's good to know
the history of a change like this when it's not on the perl list.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.