Bug 208747 - Dependency Errors in Yum and YumEx
Dependency Errors in Yum and YumEx
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-01 10:34 EDT by J. S.
Modified: 2014-01-21 17:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-20 15:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. S. 2006-10-01 10:34:57 EDT
Description of problem:
I've setup a series of screen shots on an html page which i believe is just as
good an explanation as i could do w/ words-- if not better. please view:
http://fedorashare.centrewebdesign.com/rhbugzilla/
this way, you won't have to read through my fumbled words.


Version-Release number of selected component (if applicable):
uname --all: Linux localhost.localdomain 2.6.17-1.2187_FC5 #1 Mon Sep 11
01:17:06 EDT 2006 i68 6 athlon i386 GNU/Linux
Plus, all info is visible at
http://fedorashare.centrewebdesign.com/rhbugzilla/


How reproducible:
this has been on-going w/ yum all weekend (since thurs)

Steps to Reproduce:
1. storyline is visible in screen captures. 
2. please view:
http://fedorashare.centrewebdesign.com/rhbugzilla/
3. any use of yum for a "complete update"
  
Actual results:
error - no results

Expected results:
a normal update


Additional info:
Comment 1 Seth Vidal 2006-10-01 12:20:44 EDT
nothing in those pictures tells me why you think this is a bug in yum or yumex.

it looks like an unresolvable dependency...

not a bug.

need more info if I'm going to diagnose.
Comment 2 J. S. 2006-10-01 16:50:37 EDT
hi. thanks for your attention to this.

pardon me, but i don't understand your reply. 
should i wait for more feedback from other respondents? am i going to receive 
something more about what specific info is needed from me to aide in a resolve?

if that's not what you mean-- then i don't know how to proceed, given your 
dialogue. i expect it would be recognized that this is the first i've submitted 
a 'bug report'. as far as my practice goes, there's little standard here.
Comment 3 J. S. 2006-10-02 05:29:46 EDT
I overlooked a file which I believe should belong to this series-- i had stored
in a separate folder because it occurred on 09.29.06, roughly 30 hours before
the others. 

although the other screens were captured more than 24 hours later, all actions
leading up to the failure shown in this "new" image was the same as that shown
in the previously published series-- hence the documentation of the series of
operations i published earlier.
Comment 4 J. S. 2006-10-11 04:26:09 EDT
is there a recommendation for obtaining libsyck.so.0 as 'needed by package
syck-python'? 

is there any recommended action at all?

the persistence of this problem, moreover, the absence of any feedback here is
quite discouraging. I appreciate that it's not commercial software, but ten days
is ample time for a courtesy reply. 

i am disappointed.
Comment 5 Seth Vidal 2006-10-11 09:21:14 EDT
Your disappointment is both unwarranted and inappropriate. Don't try throwing
around guilt trips. It doesn't help anything and just annoys people, mostly me.

I asked for more information and you gave me another picture. That's not helpful.

I'd like you to describe what it is you think should be happening as a narrative
or, better yet, just give me a reproducing behavior so I can see what you're
claiming is wrong. 

So far all I can see is an unresolved dependency, no bug.

Comment 6 J. S. 2006-10-20 15:10:50 EDT
thanks for acknowledging my commentary-- you didn't have to take time to do
that. I didn't realize you were expecting yet more from me-- so, although you
are annoyed by my persistence, i'm glad i posted again. if you can't appreciate
a person, especially someone who is in obvious lack of experience, not knowing
how to proceed from an instruction of "need more info" when clearly, i asked for
clairfication, how can you expect anything other than disappointment? i'm sorry
you feel the way you do-- it doesn't reflect well upon the institution which you
represent. i too work in a field in which a lot is expected of me-- often more
than i am prepared to give, and indeed it is effort to maintain a professional
discourse at times, so i can understand your frustration. 

considering the remarkable increase in the popularity of Linux, perhaps it would
do your users well if you would take a moment to consider the diverse audience
who have come to have a second-nature of relying on your assistance, and others
like you. you must remember, i'm not a part of your user-group, or your
community. again, i'm sorry that you feel the way you do about my feedback-- it
didn't mean for it to come accross as an accusation, but an honest reflection of
my feelings. inevitably, you will encounter disappointment. it's not easy to be
so honest because i do respect your superior knowledge and, of course, the
amount of effort you've given-- perhaps w/out an equal balance of reward or
recognition. in providing my honest feedback, it was an effort to promote
honest, positive growth. it is not out of disinterest, or disrespect for the
Linux community, but the contrary. if one wheel doesn't squeak, how will you
know where to put the oil?

i sincerely apologize to you if you believe that i meant harm. as far as i'm
concerned, the issue is closed.

Note You need to log in before you can comment on or make changes to this bug.