Bug 2087499 - Review Request: rust-rpm-sequoia - Implementation of the RPM PGP interface using Sequoia
Summary: Review Request: rust-rpm-sequoia - Implementation of the RPM PGP interface us...
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Michel Lind
QA Contact: Fedora Extras Quality Assurance
Depends On: 2087284
Blocks: 2130122
TreeView+ depends on / blocked
Reported: 2022-05-17 20:20 UTC by Fabio Valentini
Modified: 2022-10-14 06:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2022-10-13 21:37:34 UTC
Type: ---
michel: fedora-review+

Attachments (Terms of Use)

Description Fabio Valentini 2022-05-17 20:20:11 UTC
Spec URL: https://decathorpe.fedorapeople.org/rust-rpm-sequoia.spec
SRPM URL: https://decathorpe.fedorapeople.org/rust-rpm-sequoia-0.2.0-1.fc36.src.rpm

Implementation of the RPM PGP interface using Sequoia.

Fedora Account System Username: decathorpe

COPR build for all supported Fedora branches and architectures:

Comment 1 Fabio Valentini 2022-08-18 22:58:09 UTC
I still need to update this package to the recent 0.3.0 release, but I haven't had time to do that yet.

Comment 2 Michel Lind 2022-08-19 17:54:27 UTC
ack. flagging needinfo, let me know once the dependency is in Rawhide and you have an update, and I'll review

Comment 3 Fabio Valentini 2022-08-23 12:30:56 UTC
Spec URL: https://decathorpe.fedorapeople.org/rust-rpm-sequoia.spec
SRPM URL: https://decathorpe.fedorapeople.org/rust-rpm-sequoia-0.3.0-1.fc36.src.rpm

- updated to version 0.3.0
- updated to pseudo-rust2rpm 22
- updated to use SPDX license identifiers
- updated license listing to exclude build-time-only dependencies which are not linked into the final binary

I will refresh the license breakdown after importing / just before I build the package to make sure it's up-to-date.

Comment 4 neal 2022-09-22 09:53:43 UTC
Hi Michael,

[rpm 4.18 has been released](http://rpm.org/wiki/Releases/4.18.0) with support for the Sequoia OpenPGP backend.  To enable that backend on Fedora requires this package.  [There is interest in seeing this be the default backend for Fedora 38](https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/WCIIV7HGXW5Y7QCPKW6D3TILPOBFTCSS/).  As I understand it, to make progress on that, this package needs to be accepted.

Thanks and let me know if I can help.

Comment 5 Panu Matilainen 2022-09-26 07:00:26 UTC
This needs to be updated to 1.0.0 before proceeding, the 0.3.0 doesn't work with rpm 4.18.0 due to missing pgpPubkeyFingerprint() wrapping.

The two issues I ran into are
- soname bump (trivial to handle of course)
- new tests to cover symbol exports, which fails due to sha1collisiondetection (iirc) being too old on Fedora

Comment 6 Fabio Valentini 2022-09-30 12:10:13 UTC
I tried updating the package to v1.0.0, but it currently fails tests due to this issue:

Meanwhile, I have updated sha1collisiondetection to v0.2.6, so that should not be a problem once the aforementioned issue is resolved.

Comment 7 neal 2022-09-30 12:39:55 UTC
v1.0.1, which I just released, should fix this issue.  Thanks for reporting it.

Comment 8 Fabio Valentini 2022-09-30 13:19:29 UTC
Spec URL: https://decathorpe.fedorapeople.org/rust-rpm-sequoia.spec
SRPM URL: https://decathorpe.fedorapeople.org/rust-rpm-sequoia-1.0.1-1.fc36.src.rpm

Updated to v1.0.1, can confirm that the failing test is resolved.

Comment 9 neal 2022-09-30 13:21:49 UTC
Thanks @decathorp

Comment 10 Michel Lind 2022-10-13 18:39:47 UTC

Package Review

[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


===== MUST items =====

[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated", "GNU Library General Public License v2
     or later". 21 files have unknown license. Detailed output of
     licensecheck in /home/michel/src/fedora/reviews/2087499-rust-rpm-
[x]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package must not depend on deprecated() packages.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in rpm-
     sequoia , rpm-sequoia-devel
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Sources are verified with gpgverify first in %prep if upstream
     publishes signatures.
     Note: gpgverify is not used.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Package should compile and build into binary rpms on all supported
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.

Cannot parse rpmlint output:

Rpmlint (installed packages)
============================ rpmlint session starts ============================
rpmlint: 2.4.0
checks: 31, packages: 3

rpm-sequoia.x86_64: E: unused-direct-shlib-dependency /usr/lib64/librpm_sequoia.so.1 /lib64/libm.so.6
rpm-sequoia-devel.x86_64: W: no-documentation
rpm-sequoia.x86_64: W: invalid-license LGPL-3.0
 3 packages and 0 specfiles checked; 1 errors, 2 warnings, 1 badness; has taken 0.1 s 

Source checksums
https://crates.io/api/v1/crates/rpm-sequoia/1.0.1/download#/rpm-sequoia-1.0.1.crate :
  CHECKSUM(SHA256) this package     : 5fb273a0bb328288765b78401f9fe8ef452f322cb77aa94438606ced4b39a50a
  CHECKSUM(SHA256) upstream package : 5fb273a0bb328288765b78401f9fe8ef452f322cb77aa94438606ced4b39a50a

rpm-sequoia (rpmlib, GLIBC filtered):

rpm-sequoia-devel (rpmlib, GLIBC filtered):

rust-rpm-sequoia-debugsource (rpmlib, GLIBC filtered):




Generated by fedora-review 0.9.0 (6761b6c) last change: 2022-08-23
Command line :/usr/bin/fedora-review -b 2087499
Buildroot used: fedora-rawhide-x86_64
Active plugins: Shell-api, C/C++, Generic
Disabled plugins: Perl, Ocaml, Haskell, Java, SugarActivity, PHP, Python, fonts, R

Comment 11 Fabio Valentini 2022-10-13 18:47:26 UTC
Thanks for the review!


Comment 12 Gwyn Ciesla 2022-10-13 19:31:56 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/rust-rpm-sequoia

Comment 14 Panu Matilainen 2022-10-14 06:13:28 UTC
Thanks everybody!

I've been intending to review this myself but that was pending on me getting re-acquinted with the guidelines which would've taken some... It's been a while.

Note You need to log in before you can comment on or make changes to this bug.