Bug 208763 - adsl-connect and adsl-start fail to make a connection
adsl-connect and adsl-start fail to make a connection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rp-pppoe (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-01 14:37 EDT by Joonas Sarajärvi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 09:59:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joonas Sarajärvi 2006-10-01 14:37:45 EDT
Description of problem:
In FC5 I have been able to connect to my ISP, but in FC6 Test 3 and FC6 Pre I
haven't been able to get it connect. Instead, after using pppoe-setup and then
either /sbin/ifpu ppp0 or /sbin/adsl-start, I get this:

/sbin/adsl-start: line 216:  3203 Terminated     $CONNECT "$@" >/dev/null 2>&1

The ISP uses the pppoe protocol for connecting. It worked before and I suppose
it should still be possible for it to work.
Comment 1 Ngo Than 2006-10-30 06:38:07 EST
Joonas, which version of rp-pppoe are you using? It seems you are not using 
the rp-ppoe from FC6!

Could you please try with the rp-pppoe-3.5-32.1 and please use 
system-config-network to setup your DSL. Thanks
Comment 2 Joonas Sarajärvi 2006-10-31 08:00:46 EST
It seems the problem had something to do with my NIC driver, because I got it
working by changing to another NIC. I don't remember the exact model of the
card, but the kernel module it uses is named r1000, which wasn't included in
Fedora Core 5 or 6. I had got the driver I copmiled myself working in FC5 but I
guess it wasn't solid enough to be used in FC6. I hope the situation will
improve at some point, but until that I can now use the another NIC.

I tested with two versions of rp-pppoe. The one that came with FC6 test3/pre and
the one I downloaded from the web site of rp-pppoe. All the versions I tried
failed similarly, but I think the problem was with my NIC. Sorry for the inaccuracy.

Note You need to log in before you can comment on or make changes to this bug.