Bug 20878 - ifconfig fails to display the full name of aliases
ifconfig fails to display the full name of aliases
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-14 16:39 EST by Need Real Name
Modified: 2015-03-04 20:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 17:28:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-14 16:39:23 EST
Most people commonly name their interface aliases as eth0:1, eth0:2, etc. 
Besides tradition, there is no reason for this naming scheme. The 
following are also accepted as valid eth0:hello, eth0:world, eth0:foobar

However a problem occurs when you are using ifconfig to display the name 
of your interfaces. Ifconfig only displays the first 4 characters after 
the ':'. For example, the above names would be displayed as eth0:hell, 
eth0:worl, and eth0:foob

Therefore, any attempts to further modify eth0:hell, eth0:worl, or 
eth0:foob will fail, because their real names are stored "internally" as 
eth0:hello, eth0:world, and eth0:foobar. You can still modify an alias by 
giving its full name, but you must remember what that full alias name was, 
since ifconfig will not display it properly.

NOTE: Valid alias names may contain up to 16 characters after the ':'. To 
work properly, ifconfig should be able to display the full valid alias 
names.
Comment 1 Pekka Savola 2000-11-20 17:10:43 EST
This changes the layout of ifconfig more than a little to get room for those characters.  
Perhaps this should be taken up to the net-tools maintainer?
Comment 2 Crutcher Dunnavant 2001-04-19 14:55:07 EDT
changing the layout of ifconfig's output is dangerous, who knows how many
programs use it. leaving this for upstream to decide.
Comment 3 Phil Knirsch 2002-03-18 09:54:12 EST
Closing as a won't fix as long as the upstream maintainers don't decide to
change the original source.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.