Bug 20879 - shutdown problem
Summary: shutdown problem
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: usermode   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-14 21:49 UTC by Need Real Name
Modified: 2013-07-02 22:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 11:44:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-14 21:49:39 UTC
I just installed usermode-1.37-1.6.  After doing all the upgrades, I used
"shutdown -r +2" to reboot the machine.  According to $PATH,
/usr/bin/shutdown was executed.  The machine did not reboot, it went to
single user mode.  I thought this problem was to have been corrected in
this usermode version.

Comment 1 Need Real Name 2000-11-15 23:03:34 UTC
I replicated this problem on another machine that had been similarly upgraded. 
"/usr/bin/shutdown -r +1" still said going to maintenance mode in 1 minute and
then did go to run level 1.  "/sbin/shutdown -r +1" rebooted the machine as
expected.  The /usr/bin/shutdown script does not account for time arguments
other than "now"  and exec'd /sbin/shutdown +1 which defaults to run level 1.

Comment 2 Nalin Dahyabhai 2000-11-20 23:08:30 UTC
/sbin/shutdown should not be allowing a regular user to shut the system down to
runlevel 1.  Do you get any messages when running "rpm -yf /sbin/shutdown"? 
Which version of the SysVinit package do you have installed?

Comment 3 Need Real Name 2000-11-20 23:30:38 UTC
I was root not a regular user.  As a regular user, I would get the message
shutdown: must be root.

rpm -yf /sbin/shutdown gave:
.M?.....   /sbin/halt
.M?.....   /sbin/init
.M?.....   /sbin/killall5
.M?.....   /sbin/runlevel

SysVinit-2.78-5

/usr/bin/shutdown -r +min still should not be putting me in single user mode.



Comment 4 Jindrich Novy 2004-10-03 11:44:48 UTC
/usr/bin/shutdown was removed by errata update since Red Hat 6.2 (see
#19034). It is no more present in current releases.


Note You need to log in before you can comment on or make changes to this bug.