Bug 208810 - removing .pyc files causes rpm verification complaint
Summary: removing .pyc files causes rpm verification complaint
Status: CLOSED DUPLICATE of bug 212911
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-02 05:37 UTC by Mamoru TASAKA
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 23:06:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mamoru TASAKA 2006-10-02 05:37:38 UTC
Description of problem:
rpm transaction first upgrade packages, then remove the old
rpm packages. 

Currently system-config-display has the following %preun
scriptlets:

if [ -d /usr/share/system-config-display ] ; then
  rm -rf /usr/share/system-config-display/*.pyc
fi

So every time I upgrade system-config-display, .pyc files are
removed and rpm verification by "rpm -V system-config-display"
always complains about missing files.

Version-Release number of selected component (if applicable):


How reproducible:
system-config-display-1.0.45-1

Steps to Reproduce:
1. Upgrade system-config-display when new rpm is released
2. rpm -V system-config-display
3.
  
Actual results:
missing     /usr/share/system-config-display/monitorDialog.pyc
missing     /usr/share/system-config-display/screenSizePreview.pyc
missing     /usr/share/system-config-display/videocardDialog.pyc
missing     /usr/share/system-config-display/xConfigDialog.pyc
missing     /usr/share/system-config-display/xconf.pyc

Expected results:
No missing files.

Additional info:

Comment 2 Adam Jackson 2006-10-31 23:06:42 UTC

*** This bug has been marked as a duplicate of 212911 ***


Note You need to log in before you can comment on or make changes to this bug.