Bug 208841 - unable to handle multiple console fonts (needed for greek)
unable to handle multiple console fonts (needed for greek)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
bzcl34nup
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-10-02 08:18 EDT by Dimitris Glezos
Modified: 2008-09-24 18:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 16:42:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Keyboard selection screen not showing greek correctly (4.71 KB, image/png)
2006-10-02 08:18 EDT, Dimitris Glezos
no flags Details
Shot showing correct console font in FC6 (15.19 KB, image/png)
2006-10-02 12:34 EDT, Dimitris Glezos
no flags Details
Another shot showing the initscripts from inside the graphical boot screen. (36.77 KB, image/png)
2006-10-02 12:37 EDT, Dimitris Glezos
no flags Details
Anaconda's console font seems not OK (8.56 KB, image/png)
2006-10-02 12:59 EDT, Dimitris Glezos
no flags Details

  None (edit)
Description Dimitris Glezos 2006-10-02 08:18:00 EDT
## Description of problem:

When the installer starts (before entering graphical mode), if the user selects
"Greek" the next screens do not show greek correctly. Grapical installation is
OK, although user has to guess what buttons to choose until then.

## How reproducible:

Start a FC6 installation and choose Greek at the first screen.

## Actual results:

Greek characters are showed as squares. See attached screenshot.

## Additional info:

This discourages the user to continue the installation in greek and makes
impossible a network/HTTP install etc, since these options are made outside the
graphical mode.
Comment 1 Dimitris Glezos 2006-10-02 08:18:00 EDT
Created attachment 137535 [details]
Keyboard selection screen not showing greek correctly
Comment 2 Dimitris 2006-10-02 08:39:11 EDT
This also happens AFTER the installation.

For example, while fedora is booting, after the kernel has loaded and INIT
process has started and just before X is loaded, all Greek characters become
boxes! Like the screenshot shows from the installer.

This bug is definetly an FC6 blocker, since we plan on giving FC6 on DVDs. It
would be rather bad publicity to give a printed page with the DVD, with
instructions about the installer that shows garbage :(
Comment 3 Jeremy Katz 2006-10-02 11:26:46 EDT
I can reproduce this, but am not clear on what to do to fix it :-)

Is the console font for greek not "good"?  If you want to talk in real-time, I'm
jeremy on #fedora-devel 
Comment 4 Dimitris Glezos 2006-10-02 12:34:21 EDT
Created attachment 137561 [details]
Shot showing correct console font in FC6

The console font for FC6 is correct.
Comment 5 Dimitris Glezos 2006-10-02 12:37:30 EDT
Created attachment 137562 [details]
Another shot showing the initscripts from inside the graphical boot screen.
Comment 6 Dimitris Glezos 2006-10-02 12:54:59 EDT
Comment on attachment 137561 [details]
Shot showing correct console font in FC6

Rawhide has a correct console font for greek.
Comment 7 Dimitris Glezos 2006-10-02 12:59:31 EDT
Created attachment 137564 [details]
Anaconda's console font seems not OK

This is the console of Anaconda where greek don't show up OK.

Attachment #137561 [details] shows the console of FC6 seems OK.
Comment 8 Jeremy Katz 2006-10-02 13:53:37 EDT
Okay, I know what's going on here.  Unfortunately, given where we are time-wise,
there's not much I can do to fix it this time around.

The problem is that when we moved to using UTF-8 for the console (in 2002), we
removed the infrastructure for handling multiple console fonts from the loader.
 And adding that back at this point is non-trivial :/

For FC6, I'll change it at least so that we don't get the boxes.  For FC7, we
should look at reworking our console font infrastructure to handle multiple
console fonts again.
Comment 9 Simos Xenitellis 2006-10-04 02:16:48 EDT
My wild guess is that the console font that has been loaded with
consolechars/setfont gets cleared from memory when you start/switch to the X server.

In https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=137564 it shows that
the X server did some probing, then the console font is initialised to some
standard (non-Greek) version. Is that font defined in the kernel? What's the
case with other languages?

When a user installs Fedora with Greek support, the font specified in
/etc/sysconfig/??i18n?? is the one that supports English and Greek. In this
situation there is no need for multiple console fonts from the loader, just this
single Greek Unicode console font.
Comment 10 Dimitris Glezos 2006-10-29 16:09:40 EST
Jeremy, any chance we get this fixed before fc7t1 or fc7t2?
Comment 11 Jeremy Katz 2006-10-30 14:09:25 EST
I've put it on the FC7 list; it's mostly a matter of time to sit down and get
things working again.  Patches cheerfully accepted :)
Comment 12 Simos Xenitellis 2006-10-31 02:52:10 EST
I'ld recommend to change the title of the report from 
OLD: "unable to handle multiple console fonts (needed for greek)"
to
NEW: "(greek) console font cannot be set permanently on Linux console".

There is a utility, "showcfont" (or "showconsolefont"), that shows the current
codepage loaded on your console. It can be useful to show how the fonts look
like when you switch between X and console, and help narrow down where the
problems starts from.
Comment 13 Stephanos Manos 2007-02-25 12:42:06 EST
Still present in f7test2.
Also with the changes to /etc/profile.d/lang.sh (fix for BZ# 229102) text mode
startup and shutdown is displayed in boxes. BZ# 229996
Comment 14 Stephanos Manos 2007-03-03 15:13:07 EST
(In reply to comment #2)
> This also happens AFTER the installation.
> 
> For example, while fedora is booting, after the kernel has loaded and INIT
> process has started and just before X is loaded, all Greek characters become
> boxes! Like the screenshot shows from the installer.
> 
This is a gdm/X bug and a quite annoying one because if x fails to start (errors
in xorg) and the system continues to boot in text mode you get boxes until
lang.sh is run and it is reproducible after boot i.e. login to a vt and issue
gdm-restart you will get strange chars and boxes even for english text.
Comment 15 Dimitris Glezos 2007-04-04 09:56:32 EDT
Ping.

Jeremy, any news on this?
Comment 16 Matthew Miller 2007-04-06 14:48:26 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 17 Stephanos Manos 2007-04-06 15:50:29 EDT
Still present in f7test3
Comment 18 Matthew Miller 2007-04-06 16:01:59 EDT
Thanks!
Comment 19 Nikos Charonitakis 2007-04-29 16:19:53 EDT
Still present in f7test4. Text mode installation for greek is unusable.
Comment 20 Bug Zapper 2008-04-03 14:23:59 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 21 Nikos Charonitakis 2008-04-03 14:39:13 EDT
This bug is still valid. Greek text mode installation is not available and when
a user switches from terminal to X greek fonts turn to garbage. You can see it
even at boot time (in a system with greek as default language) at the point X is
loaded.
Comment 22 Bug Zapper 2008-05-13 22:23:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Jeremy Katz 2008-05-28 16:42:27 EDT
text mode is generally deprecated in preference of making sure that the
graphical installer just works everywhere.  For the cases where that's not
possible, kickstart and minimal display of progress will remain, but non-localized.

I've made it so that we fallback and correctly tell you that Greek isn't support
for a text-mdoe install now, though.
Comment 24 Nikos Charonitakis 2008-05-29 19:45:47 EDT
(In reply to comment #23)
> text mode is generally deprecated in preference of making sure that the
> graphical installer just works everywhere.  For the cases where that's not
> possible, kickstart and minimal display of progress will remain, but
non-localized.


Does this mean that you removing text mode installation option for all languages?
If this is not the case. I think that this bug should not close or we have to
open another bug report to a more appropriate component (which one?) than anaconda.
As i noticed before this is not an anaconda specific problem, Greek console
fonts are not displayed properly in general.

Comment 25 Nikos Charonitakis 2008-09-24 16:16:16 EDT
fedora f10 alpha. New strange font behaviour...
During non graphical boot or shut down Greek characters are displayed as 2-3 specific greek characters that does not make any sense (i think are: xi, omega and zeta)
Really very ugly and non user friendly situation. Please reopen using the appropriate component.
Comment 26 Simos Xenitellis 2008-09-24 18:19:32 EDT
What I guess is going on:

1. The translation messages are correct UTF-8, Greek strings.
2. The console is configured to 8-bit mode (iso-8859-7), not Unicode.
3. The UTF-8 encoded strings are shown as if they are encoded in the iso-8859-7 legacy encoding.

Do the strings look like

$ echo 'Αυτά είναι ελληνικά.' | iconv -f iso-8859-7 -t utf-8
Αυτά Ρίναι Ρλληνικά.
$ _

The solution is to have the console always in Unicode mode.

The default keyboard layout for the console requires dead keys, something that is not supported in the Linux kernel, and something that needs to be supported in the terminal emulation program (not available, afaik, 'jfbterm'?).
If there is interest for a Greek keyboard layout for the console, there should be a variant created that does not require dead keys.

Even if it is not possible to type accents in console mode, the console should be in Unicode mode.

Note You need to log in before you can comment on or make changes to this bug.