Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 20885 - ncpfs and netware 5.1 servers...
ncpfs and netware 5.1 servers...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ncpfs (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-14 17:53 EST by Need Real Name
Modified: 2015-03-04 20:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 06:08:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-14 17:53:25 EST
When attempting to mount a volume on a netware 5.1 server with ncpfs 
version 2.2.0.18 (via ncpmount -v), I get the following:

[robertcn@thirdspace robertcn]$ ncpmount -U<username> -S<server> nds/
Logging into <server> as <user>
Password:
ncpmount: No referrals (-634) in nds login
Login denied.

If, however, I log into the same server from a 6.2 box running ncpfs 
version 2.2.0.12 (via ncpmount -v), it works fine.

I haven't tried back reving the package, but I would rather not do so if 
not completely necessary.

Thanks
Comment 1 Need Real Name 2000-11-14 18:01:31 EST
Ooops.  The version of Redhat that the ncpfs wasn't broken on was a 6.0 box.
Comment 2 Alastair Channon 2001-10-10 17:27:51 EDT
I've just run into this exact error, and worked-around the problem.  
On our network 7.1 users could not connect to some of the Netware
shares/servers.  6.1 users could connect to all.    
The problem exists in 7.1, but not in 6.1.  I'm not sure about 6.2 or 7.0.

So a work-around is to revert to the version of ncpfs that was in RedHat 6.1:

1. Download ncpfs-2.2.0.16.a-1.src.rpm from
ftp://ftp.redhat.com/pub/redhat/linux/6.1/en/os/i386/SRPMS/

2. As superuser:
rpm -e ncpfs-2.2.0.18-3
rpm --rebuild ncpfs-2.2.0.16.a-1.src.rpm
cd /usr/src/redhat/RPMS/i386
rpm -ivh ncpfs-2.2.0.16.a-1.i386.rpm

Redhat: It would be great to have this fixed in a future release.  And perhaps
an update for 7.2 if it's not fixed in that.  I don't have a copy as it has not
been released yet. 

Best wishes,
Alastair.
Comment 3 Need Real Name 2001-10-10 18:50:57 EDT
A note as I have been remiss in keeping track of this bug.  If you need to log 
into an nds server with ncpfs and the server is IP only, use the -A flag and 
give it the FQDN of the server (or just the server name if you have resolv.conf 
looking up the right address) and it'll work as well.
Comment 4 Phil Knirsch 2002-01-17 06:08:19 EST
As this seems to be more of a configuration issue and the comments already
provide a workaround resp. a correct configuration for the problem i'm closing
the bug as NOTABUG.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.