Bug 208851 - drop foo2zjs, foo2oak, foo2hp files from foomatic
drop foo2zjs, foo2oak, foo2hp files from foomatic
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: Reopened
: 149055 (view as bug list)
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2006-10-02 09:16 EDT by David Woodhouse
Modified: 2009-01-19 07:34 EST (History)
4 users (show)

See Also:
Fixed In Version: foomatic-3.0.2-70.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 07:34:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2006-10-02 09:16:08 EDT
There's a foo2zjs printer driver in Livna now. The current foo2zjs has its own
foomatic files, with options like a 'Draft Quality' which aren't supported by
what we ship.

How should we handle this -- should foo2zjs ship the files describing its own
driver, and should we drop them from the foomatic package entirely? Without the
driver being installed, its configuration files are presumably useless anyway.

We also ship configuration stuff for foo2oak, which was a GPL violation and has
since been discontinued.
Comment 1 David Woodhouse 2006-10-02 09:35:07 EDT
In particular we need to default to 'No ICM color correction', since it doesn't
have the ICM files installed by default and in fact shouldn't be trying to use
them these days anyway AFAICT.
Comment 2 Tim Waugh 2006-10-02 10:14:48 EDT
If possible we should remove the foomatic XML files for it.  This affects the
following printer models, which currently list foo2zjs as the recommended driver:

Generic-ZjStream_Printer.xml
HP-LaserJet_1000.xml
HP-LaserJet_1005.xml
Minolta-Color_PageWorks_Pro_L.xml
Minolta-magicolor_2200_DL.xml
Minolta-magicolor_2300_DL.xml
Minolta-magicolor_2430_DL.xml

I should probably patch them to use whichever other driver is available, or else
remove them if none is available.
Comment 3 David Woodhouse 2006-10-02 11:11:31 EDT
There is no other driver available -- the protocol used with these printers is
possibly afflicted by patents (http://www.cl.cam.ac.uk/~mgk25/jbigkit/patents.html).

jbigkit and the foo2zjs driver are in Livna, and we can fix the Livna package to
provide the matching foomatic database entries -- so it's probably best to
remove anything referring to foo2zjs, foo2oak and foo2hp from the Fedora
foomatic package.
Comment 4 Fedora Update System 2006-11-13 15:44:40 EST
Fixed in update: foomatic-3.0.2-39.1.fc6
Comment 5 Deji Akingunola 2007-04-13 15:28:20 EDT
This is actually not fixed yet. The 'fix' might have be applied in the wrong
place as the foo2zjs files still exist under /usr/share/foomatic/db/source in
foomatic-3.0.2-46.fc7. The removal of these files in the rpm spec should
probably be done after the %install section.
Comment 6 Tim Waugh 2007-04-23 07:48:13 EDT
Please try foomatic-3.0.2-39.5.fc6 from updates-testing:

yum --enablerepo=updates-testing update foomatic
Comment 7 Tim Waugh 2007-06-08 05:51:01 EDT
*** Bug 149055 has been marked as a duplicate of this bug. ***
Comment 8 Andreas Bierfert 2007-12-29 10:21:46 EST
This is still not fixed in F8. Could somebody take care of it?

Transaction Check Error:
  file /usr/share/foomatic/db/source/printer/Samsung-CLP-300.xml from install of
foo2qpdl-0.20070822-1.lvn8.x86_64 conflicts with file from package
foomatic-3.0.2-52.fc8.x86_64
  file /usr/share/foomatic/db/source/printer/Samsung-CLP-600.xml from install of
foo2qpdl-0.20070822-1.lvn8.x86_64 conflicts with file from package
foomatic-3.0.2-52.fc8.x86_64
  file /usr/share/foomatic/db/source/printer/Xerox-Phaser-6115MFP.xml from
install of foo2qpdl-0.20070822-1.lvn8.x86_64 conflicts with file from package
foomatic-3.0.2-52.fc8.x86_64
Comment 9 Tim Waugh 2008-01-07 11:34:21 EST
Fixed in CVS.
Comment 10 Fedora Update System 2008-01-11 17:17:18 EST
foomatic-3.0.2-53.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'
Comment 11 Fedora Update System 2008-02-01 20:19:31 EST
foomatic-3.0.2-53.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Michael Sidenius 2008-03-20 07:45:40 EDT
There seems to still be a problem with overlapping files, when installing
foo2qpld from Livna (please refer to
https://bugzilla.redhat.com/show_bug.cgi?id=438319)
Comment 13 Kevin Kofler 2008-12-08 15:10:32 EST
Looks like we have yet another such conflict:
> foo2oak-0.20080826-1.fc10.i386  in  rpmfusion-free-development-i686
>   File conflict with: foomatic-3.0.2-68.fc11.i386
>      /usr/share/foomatic/db/source/printer/HP-Color_LaserJet_1500.xml
Comment 14 Tim Waugh 2009-01-19 07:34:51 EST
Fixed again.

Note You need to log in before you can comment on or make changes to this bug.