Bug 208856 - Cannot debug C/C++ program
Summary: Cannot debug C/C++ program
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-02 13:35 UTC by Andrew Overholt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 18:50:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
workspace/.metadata/.log snippet (1.40 KB, text/plain)
2006-10-02 13:35 UTC, Andrew Overholt
no flags Details

Description Andrew Overholt 2006-10-02 13:35:39 UTC
Description of problem:
Cannot debug C/C++ program

Version-Release number of selected component (if applicable):
eclipse-cdt-3.1.1-1.fc6
gdb-6.5-8.fc6

How reproducible:
?  Always for me.

Steps to Reproduce:
1. New->C->Managed Make project
2. New->C->Source file
3. Add main method, add printf("blah\n");
4. Add breakpoint on printf statement

Actual results:
Error:  "Failed to set program arguments, environment, or working directory"

Expected results:
Switch to debug perspective and stop on breakpoint

Additional info:
It seems to be some sort of MI error.  This is printed in the Eclipse console:

No symbol "new" in current context.
mi_cmd_env_cd: Usage DIRECTORY

Comment 1 Andrew Overholt 2006-10-02 13:35:39 UTC
Created attachment 137541 [details]
workspace/.metadata/.log snippet

Comment 2 Jeff Johnston 2006-10-12 18:50:32 UTC
Works fine on local FC6 system with updated gcc (includes patch to fix project
save error).


Note You need to log in before you can comment on or make changes to this bug.