Bug 2088656 - Dead keys in plasmashell doesn't work with ibus under wayland
Summary: Dead keys in plasmashell doesn't work with ibus under wayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-20 00:26 UTC by Renan Birck Pinheiro
Modified: 2022-06-15 01:30 UTC (History)
12 users (show)

Fixed In Version: ibus-1.5.26-8.fc36 ibus-1.5.26-9.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-06 02:11:04 UTC
Type: Bug


Attachments (Terms of Use)
Video showing that it works for me (169.97 KB, video/mp4)
2022-05-26 20:06 UTC, Mike FABIAN
no flags Details
screenshot showing Portuguese layout in ibus-setup but English layout in the ibus panel menus (152.18 KB, image/png)
2022-06-08 07:33 UTC, Mike FABIAN
no flags Details
Another confusing screenshot (214.49 KB, image/png)
2022-06-08 09:15 UTC, Mike FABIAN
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker FC-469 0 None None None 2022-06-09 03:01:32 UTC

Description Renan Birck Pinheiro 2022-05-20 00:26:28 UTC
Description of problem:
After updating to Fedora 36, dead keys (used to make special characters like áéíóúã) don't work under Plasma in Wayland if ibus is running, even if the layout is set to (e.g.) Brazilian

If ibus is removed, they work. 


Version-Release number of selected component (if applicable):
5.24.5

How reproducible:
if I create a new user, this problem happens

Steps to Reproduce:
1. on a new user account, use Plasma + Wayland. Set keyboard layout to Brazilian
2. you will be unable to type áéíóú etc...
3.

Actual results:
be able to type characters with dead keys

Expected results:
am unable to type these characters

Additional info:

Comment 1 Geraldo Simião 2022-05-25 17:20:31 UTC
I can confirm that too:

ibus-qt-1.3.3-33.fc36.x86_64 / ibus-libs-1.5.26-6.fc36.x86_64 / ibus-gtk2-1.5.26-6.fc36.x86_64 / ibus-gtk3-1.5.26-6.fc36.x86_64 / ibus-1.5.26-6.fc36.x86_64 / ibus-gtk4-1.5.26-6.fc36.x86_64
Operating System: Fedora Linux 36
KDE Plasma Version: 5.24.90
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.3
Kernel Version: 5.17.9-300.fc36.x86_64 (64-bit)
Graphics Platform: Wayland

Comment 2 Mike FABIAN 2022-05-26 20:06:03 UTC
Created attachment 1883971 [details]
Video showing that it works for me

Works for me, see attached video.

In the video, I use the Brazilian Portuguese keyboard layout first together with ibus-anthy (Japanese input method) and switch ibus-anthy into Latin mode (Only in Latin mode dead keys work when ibus-anthy is used). I can type a dead_acute followed by an a and get á. 

Then I switch to ibus-typing-booster and type again dead_acute followed by a and again get á. 

After typing the dead_acute before the a is typed, an accute accent is shown as a preview. 

When stopping ibus and typing dead_acute followed by a again, I still get á, i.e. the dead keys also work without ibus. But without ibus one does not get the preview after typing only dead_acute.

What ibus input methods are you using when this doesn't work?

Can you make screenshots or videos to show exactly what doesn't work please?

Comment 3 Mike FABIAN 2022-05-27 10:30:56 UTC
I can reproduce the problem by doing this:

- use im-chooser to select ibus
- Open ibus-setup and remove all input methods except the “English (US)” keyboard layout
- Add us and br keyboard layouts in the KDE control center
- reboot
- Select the br layout in the panel

Now ibus is running but there is no ibus icon in the kde panel and dead keys don't work.

Comment 4 Geraldo Simião 2022-05-27 18:21:01 UTC
Tested now the new build (ibus-1.5.26-7.fc36.x86_64) at this update https://bodhi.fedoraproject.org/updates/FEDORA-2022-912bd4be77 and until now it seems the bug isn't here anymore. Will test further to see if its really solved.

Comment 5 Geraldo Simião 2022-05-27 18:30:42 UTC
Sorry, just after one reboot bug is back, even with new ibus build.

Comment 6 Mike FABIAN 2022-05-30 08:49:37 UTC
(In reply to Mike FABIAN from comment #3)
> I can reproduce the problem by doing this:
> 
> - use im-chooser to select ibus
> - Open ibus-setup and remove all input methods except the “English (US)”
> keyboard layout
> - Add us and br keyboard layouts in the KDE control center
> - reboot
> - Select the br layout in the panel
> 
> Now ibus is running but there is no ibus icon in the kde panel and dead keys
> don't work.

I can still reproduce it exactly like that with ibus-1.5.26-7.fc36.x86_64

Comment 7 Mike FABIAN 2022-05-30 13:52:50 UTC
(In reply to Mike FABIAN from comment #6)
> (In reply to Mike FABIAN from comment #3)
> > I can reproduce the problem by doing this:
> > 
> > - use im-chooser to select ibus
> > - Open ibus-setup and remove all input methods except the “English (US)”
> > keyboard layout
> > - Add us and br keyboard layouts in the KDE control center
> > - reboot
> > - Select the br layout in the panel
> > 
> > Now ibus is running but there is no ibus icon in the kde panel and dead keys
> > don't work.
> 
> I can still reproduce it exactly like that with ibus-1.5.26-7.fc36.x86_64

If I do all the above but use only the “Portuguese - Portuguese (Brazil)” keyboard in ibus-setup, it makes no difference, the same happens i.e. dead keys don’t work.

Comment 8 Mike FABIAN 2022-05-30 13:55:18 UTC
Hi Geraldo and Renan, 

can you describe in more detail what you did? Did you add any input methods in ibus-setup, if yes which ones?

Did you add keyboard layouts in the KDE control centre? Which ones?

Comment 9 Mike FABIAN 2022-05-31 06:42:44 UTC
On the Portuguese Brazil keyboard layout, typing the key to the right of the `P` should give a dead_acute so typing that key followed by `a` should give `á`:

https://en.wikipedia.org/wiki/Portuguese_keyboard_layout#/media/File:KB_Portuguese_Brazil.svg

Comment 10 fujiwara 2022-06-02 07:36:43 UTC
(In reply to Mike FABIAN from comment #9)
> On the Portuguese Brazil keyboard layout, typing the key to the right of the
> `P` should give a dead_acute so typing that key followed by `a` should give
> `á`:
> 
> https://en.wikipedia.org/wiki/Portuguese_keyboard_layout#/media/File:
> KB_Portuguese_Brazil.svg

Thank you for the info.

Seems systemsettings5 cannot change Compose key position and I could not test this as xmodmap also does not work for Wayland.

Comment 11 fujiwara 2022-06-02 07:39:20 UTC
IBus has to handle the compose keys since QtIMModule does not fall back the key events.

Comment 12 Fedora Update System 2022-06-02 10:15:01 UTC
FEDORA-2022-912bd4be77 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-912bd4be77

Comment 13 Fedora Update System 2022-06-03 04:17:15 UTC
FEDORA-2022-912bd4be77 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-912bd4be77`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-912bd4be77

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2022-06-06 02:11:04 UTC
FEDORA-2022-912bd4be77 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Mike FABIAN 2022-06-08 07:33:37 UTC
Created attachment 1887881 [details]
screenshot showing Portuguese layout in ibus-setup but English layout in the ibus panel menus

I tried to test whether the update fixes the problem. I think it does.

When I repeat the test described in this comment

https://bugzilla.redhat.com/show_bug.cgi?id=2088656#c7

it works!

When I have only the “Portuguese - Portuguese (Brazil)” set in ibus-setup and the us and the br keyboard layouts set in the KDE control center, select the br layout and reboot, then the dead keys work after the reboot. No ibus icon is shown in the panel then. 


There is some weird behaviour though: 

If I add another input method in ibus-setup, for example ibus-typing-booster in addition to the “Portuguese - Portuguese (Brazil)” layout, and reboot again, then dead keys still work fine and are apparently handled by ibus as I see the dead key preview. 

In the panel I see an ibus icon now. Clicking on it shows me a menu with ibus-typing-booster and the “English - English (US)” keyboard layout. 
Which is a bit weird because in ibus-setup there is the “Portuguese - Portuguese (Brazil)” layout!

On top of that there is the already known problem that the ibus menus from the panel sometimes don’t close correctly, in the screenshot one sees the menu shown on left mouse click and the one shown on right mouse click at the same time!

Comment 16 Mike FABIAN 2022-06-08 07:41:46 UTC
(In reply to Mike FABIAN from comment #15)

> On top of that there is the already known problem that the ibus menus from
> the panel sometimes don’t close correctly, in the screenshot one sees the
> menu shown on left mouse click and the one shown on right mouse click at the
> same time!

See: https://bugzilla.redhat.com/show_bug.cgi?id=1936942
for the problem of the menus not closing.

Comment 17 Mike FABIAN 2022-06-08 09:15:07 UTC
Created attachment 1887942 [details]
Another confusing screenshot

Another screenshot which is even more confusing because I added French, German, and Portuguese layouts in ibus-setup and two input methods (ibus-typing-booster  and ibus-anthy).

The panel menu shows only ibus-typing-booster, ibus-anthy, and the “English - English (US)” layout which doesn't even appear in the list of configured input methods in ibus-setup. 

The existence of that “English - English (US)” layout in the panel seems to fix the dead key problem, apparently if a layout is there, ibus handles the dead keys. 

And showing the other layouts configured in ibus-setup in the panel probably makes no sense because ibus cannot switch the keyboard layouts in Plasma(Wayland) anyway. 

So it is certainly an improvement because it fixes the dead key problem but it looks confusing.

Comment 18 Fedora Update System 2022-06-11 14:01:09 UTC
FEDORA-2022-779954d5e0 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-779954d5e0

Comment 19 Geraldo Simião 2022-06-12 00:04:03 UTC
(In reply to Fedora Update System from comment #18)
> FEDORA-2022-779954d5e0 has been submitted as an update to Fedora 36.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-779954d5e0

Using it for a few hours now. Until now, no bugs. Have rebooted two times, to be sure, and it seems bug is really gone this time (at least in Pt-Br).

Comment 20 Fedora Update System 2022-06-12 01:41:30 UTC
FEDORA-2022-779954d5e0 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-779954d5e0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-779954d5e0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2022-06-15 01:30:24 UTC
FEDORA-2022-779954d5e0 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.