Bug 208866 - Missing pnmtopng(1) in the latest update
Summary: Missing pnmtopng(1) in the latest update
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-02 14:05 UTC by Jan Kratochvil
Modified: 2013-07-02 23:17 UTC (History)
2 users (show)

Fixed In Version: netpbm-progs-10.35-6.fc6.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 20:59:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Kratochvil 2006-10-02 14:05:07 UTC
Description of problem:
In the recent RawHide update the pnmtopng(1) program is missing.

Version-Release number of selected component (if applicable):
netpbm-progs-10.35-3.fc6.i386

How reproducible:
Always.

Steps to Reproduce:
1. pnmtopng
  
Actual results:
-bash: pnmtopng: command not found

Expected results:
Started pnmtopng(1).

Additional info:
$ rpm -qlv netpbm-progs|grep pnmtopng
-rw-r--r--    1 root    root             5892 Sep 18 13:14
/usr/share/man/man1/pnmtopng.1.gz
$ _

Comment 1 Jindrich Novy 2006-10-02 14:55:28 UTC
looks like a brew issue, pnmtopng is included with no problem in netpbm-progs
when  it's build locally. Trying to rebuild...

Comment 2 Jesse Keating 2006-10-02 15:23:22 UTC
The issue actually was libpng-devel's fault for not requiring pkgconfig. 
libpng-devel has a png-config which in turn calls pkg-config.  However no
Requires was present and thus it wasn't in the buildroot.  I've rebuilt libpng
and as soon as it hits the buildroots I'll rebuild netpbm.

Comment 3 Jan Kratochvil 2006-10-02 20:59:33 UTC
Tested in
http://armstrong.rhts.boston.redhat.com/distros/rawhide-i386/Fedora/RPMS/netpbm-progs-10.35-6.fc6.i386.rpm

that pnmtopng(1) is already present there.



Note You need to log in before you can comment on or make changes to this bug.