Bug 208892 - fix for 208011 causes segfault in rgmanager during fail->disable transition
fix for 208011 causes segfault in rgmanager during fail->disable transition
Status: CLOSED UPSTREAM
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks: 208011
  Show dependency treegraph
 
Reported: 2006-10-02 11:03 EDT by Lon Hohberger
Modified: 2009-04-16 16:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:11:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2006-10-02 11:03:22 EDT
Description of problem:

When a service is moved from the failed state to the disabled state (by
disabling the service again), clurgmgrd often crashes because of a missing
format parameter.

Version-Release number of selected component (if applicable): CVS/RHEL4


How reproducible: 50-60%


Steps to Reproduce:
1.  Run clurgmgrd -f
2.  Start a service
3.  Disable the service (But make the stop fail)
4.  Disable the service again
  
Actual results:

Service goes in to failed state at step 3 (good).
clurgmgrd crashes in step 4 (bad)

Expected results:

No crash, and "Alert: Marking X as 'disabled', but some resources may still be
allocated" or similar warning message in logs.

Additional info:

Caused by a missing format specifier.

Patch in CVS:

http://sourceware.org/cgi-bin/cvsweb.cgi/cluster/rgmanager/src/daemons/rg_state.c.diff?cvsroot=cluster&only_with_tag=RHEL4&r1=1.4.2.15&r2=1.4.2.16

Note You need to log in before you can comment on or make changes to this bug.