Bug 2089176 - SELinux is preventing 10-sendmail from read, open access on the file /usr/bin/systemctl.
Summary: SELinux is preventing 10-sendmail from read, open access on the file /usr/bin...
Keywords:
Status: CLOSED DUPLICATE of bug 2089175
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 36
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e24df863cd45c3600d3c51509c9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-23 07:29 UTC by Kamil Páral
Modified: 2022-05-23 09:15 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-23 09:15:48 UTC
Type: ---


Attachments (Terms of Use)

Description Kamil Páral 2022-05-23 07:29:54 UTC
Description of problem:
I upgraded my F36 Workstation and rebooted. This is the first time I see this error, so it must be related to the recent update.
SELinux is preventing 10-sendmail from read, open access on the file /usr/bin/systemctl.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that 10-sendmail should be allowed read open access on the systemctl file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c '10-sendmail' --raw | audit2allow -M my-10sendmail
# semodule -X 300 -i my-10sendmail.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_dispatcher_custom
                              _t:s0
Target Context                system_u:object_r:systemd_systemctl_exec_t:s0
Target Objects                /usr/bin/systemctl [ file ]
Source                        10-sendmail
Source Path                   10-sendmail
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           systemd-250.3-8.fc36.x86_64
SELinux Policy RPM            selinux-policy-targeted-36.9-1.fc36.noarch
Local Policy RPM              selinux-policy-targeted-36.9-1.fc36.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.17.9-300.fc36.x86_64 #1 SMP
                              PREEMPT Wed May 18 15:08:23 UTC 2022 x86_64 x86_64
Alert Count                   1
First Seen                    2022-05-23 09:25:13 CEST
Last Seen                     2022-05-23 09:25:13 CEST
Local ID                      467e6b9f-5aec-41c3-a344-ac769f6db9a5

Raw Audit Messages
type=AVC msg=audit(1653290713.727:246): avc:  denied  { read open } for  pid=1396 comm="10-sendmail" path="/usr/bin/systemctl" dev="dm-0" ino=1836519 scontext=system_u:system_r:NetworkManager_dispatcher_custom_t:s0 tcontext=system_u:object_r:systemd_systemctl_exec_t:s0 tclass=file permissive=1


Hash: 10-sendmail,NetworkManager_dispatcher_custom_t,systemd_systemctl_exec_t,file,read,open

Version-Release number of selected component:
selinux-policy-targeted-36.9-1.fc36.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.17.1
hashmarkername: setroubleshoot
kernel:         5.17.9-300.fc36.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2022-05-23 09:15:48 UTC

*** This bug has been marked as a duplicate of bug 2089175 ***


Note You need to log in before you can comment on or make changes to this bug.