Bug 208921 - Underline isn't rendered at the proper place
Underline isn't rendered at the proper place
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On: 206397
Blocks: 211261
  Show dependency treegraph
 
Reported: 2006-10-02 13:07 EDT by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 20:29:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-10-02 13:07:02 EDT
+++ This bug was initially created as a clone of Bug #206397 +++

Description of problem:
When you type the Hangul, underline appears in preedit.  However it doesn't
appear at the bottom of the letter but 5~10% up from the bottom where I expected
it to appear.

For Hangul, underline in preedit interferes with input since it is one letter
at a time.  Indeed Windows(ime2002) doesn't use underline for Hangul either.

How reproducible:
always

Steps to Reproduce:
1. run gedit and increase the font size
2. activate the scim-hangul
3. type"rnr" <--"๊ทน"
  
Actual results:
Preedit has underline towards bottom of preedit which is confusing.

Expected results:
No underline for Hangul.

-- Additional comment from tagoh@redhat.com on 2006-09-14 01:51 EST --
Well, appearing the underline isn't a bug since scim-hangul uses the preedit.
however rendering it at a character 5~10% upper looks like a Pango or freetype
bug, or font perhaps. reassigning to pango for now.

-- Additional comment from besfahbo@redhat.com on 2006-09-14 11:36 EST --
Attach screenshots please if you can.  And which font is it?  I probably can
reproduce using the font only.

-- Additional comment from jko@redhat.com on 2006-09-14 20:10 EST --
Sorry I can't make screenshots because of pre-editing state.
It is default korean font(Baekmuk), and it is included on FC and RHEL as well

-- Additional comment from sangu@hellocity.net on 2006-09-15 07:46 EST --
Created an attachment (id=136345)
Typing hangul with scim-hangul, Preedit with Underline on gedit.

This problem doesn't happen in nabi or imhangul.
nabi and imhangul are hangul input method.


-- Additional comment from sangu@hellocity.net on 2006-09-19 02:08 EST --
Created an attachment (id=136604)
preedit of scim-hangul on openoffice writer

The same problem happens on openoffice writer.
So this problem isn't pango bug and scim bug.

-- Additional comment from sangu@hellocity.net on 2006-09-19 02:16 EST --
So this problem isn't pango bug but scim bug, maybe.

-- Additional comment from sangu@hellocity.net on 2006-09-19 02:54 EST --
Patch (Default underline preedit attributes is not appropriate) : 
http://sourceforge.net/mailarchive/forum.php?thread_id=30576356&forum_id=43684

-- Additional comment from jko@redhat.com on 2006-09-19 22:30 EST --
The Main problem is SCIM, becuase Hangul doesn't need a underline.
I discussed with sangu and krisna. krisna said that GTK2 and XIM is using
Underline from SCIM, and he said Hangul doesn't need it.

However, Underline should be fixed in Pango as well.

-- Additional comment from sangu@hellocity.net on 2006-09-19 23:00 EST --
See Also : another underline problem in pango - bug 204016

-- Additional comment from petersen@redhat.com on 2006-09-29 12:03 EST --
A patch related to this for gtkimm has been committed upstream:

[Scim-cvs] scim/extras/gtk2_immodule gtkimcontextscim.cpp, 1.170.2.7,	1.170.2.8

-- Additional comment from petersen@redhat.com on 2006-10-02 12:57 EST --
This should be fixed now for the scim gtkimm and xim in scim-1.4.4-35.fc6
with patches from upstream cvs.  I will open another bug for scim-bridge.
Comment 1 Jens Petersen 2006-10-18 03:36:05 EDT
Thanks to Dairiki-san, this seems to be fixed in current scim-bridge cvs too.
Comment 2 Jens Petersen 2006-10-18 22:28:26 EDT
This should be fixed in the next devel build.
Comment 3 Fedora Update System 2006-10-24 16:18:09 EDT
scim-bridge-0.4.7-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Fedora Update System 2006-11-02 16:44:49 EST
scim-bridge-0.4.7-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.