Bug 209005 - ext3/jbd panic
ext3/jbd panic
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 17:49 EDT by Dave Jones
Modified: 2015-01-04 17:28 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 19:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console capture (6.51 KB, text/plain)
2006-10-02 17:51 EDT, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2006-10-02 17:49:43 EDT
I ran two fsx instances on a local 2 disk RAID0 mount, one on an NFS mount, and
an fs-stress run on the same local RAID0.  After about 10 minutes, it went bang
with the attached oopses/panic.
Comment 1 Dave Jones 2006-10-02 17:51:04 EDT
Created attachment 137603 [details]
serial console capture
Comment 2 Eric Sandeen 2006-10-02 18:33:08 EDT
Dave, first quick thought is this might be a dup of bugs #208404 / #207739

In case you want to re-test w/ that patch...

I'll need to dig up the exact trees that these problems were reported on to make
sure it's the same BUG_ON we're hitting.
Comment 3 Eric Sandeen 2006-10-02 22:32:08 EDT
Ok, it was wishful thinking that this is a dup of those bugs.  Although, it may
still be the root cause.  The patch which "fixed" those bugs is in this oopsing
kernel, but it wound up at pretty much the same place.
Comment 5 Eric Sandeen 2006-10-03 12:42:12 EDT
I'll look into this a bit.
Comment 6 Eric Sandeen 2006-10-05 14:09:26 EDT
Can't seem to reproduce this on anything but Dave's box...  

From the attached oops, we went down the path of the last call to
journal_do_submit_data in journal_submit_data_buffers, I think.
Comment 8 Eric Sandeen 2006-10-10 11:37:01 EDT
At long last, I can hit this one now too.

The key is that it needs a block size < page size to hit it, I think.  Although,
it still took many hours for me to hit it (about 12...)

As we gain understanding of the bug I'll try to whip up a better testcase.
Comment 9 Dave Jones 2006-10-16 19:57:45 EDT
This should be fixed in todays FC6 kernel.

Note You need to log in before you can comment on or make changes to this bug.