Bug 20901 - No utmp entry for non-:0 displays
No utmp entry for non-:0 displays
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: Security, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-15 06:57 EST by Tim Waugh
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-10 20:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here are the required xdm-config changes (906 bytes, patch)
2000-11-15 06:58 EST, Tim Waugh
no flags Details | Diff
Here's an Xstartup file (254 bytes, text/plain)
2000-11-15 06:59 EST, Tim Waugh
no flags Details
Here's an Xreset file (256 bytes, patch)
2000-11-15 06:59 EST, Tim Waugh
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 2959 None None None Never

  None (edit)
Description Tim Waugh 2000-11-15 06:57:00 EST
Displays :1 and up don't get utmp entries!
Comment 1 Tim Waugh 2000-11-15 06:58:12 EST
Created attachment 5381 [details]
Here are the required xdm-config changes
Comment 2 Tim Waugh 2000-11-15 06:59:13 EST
Created attachment 5382 [details]
Here's an Xstartup file
Comment 3 Tim Waugh 2000-11-15 06:59:44 EST
Created attachment 5383 [details]
Here's an Xreset file
Comment 4 Mike A. Harris 2001-08-15 09:38:10 EDT
Deferred for next major release
Comment 5 Mike A. Harris 2002-08-08 02:55:29 EDT
This is my lowest numbered still-open bug report.  ;o)

I meant to do this for our next release, but it is something
that should have went into beta 1 or 2, so I'm not comfortable
doing it right now.

Once our final release is out, I will look into this for rawhide
as we go for XFree86 4.3.0.

Please remind me if you like, as this bug is wayyyy off the bottom
of my Mozilla window.  ;o)
Comment 6 Mike A. Harris 2002-12-21 14:58:21 EST
Ok, I've looked at these files and am considering integrating them into
a build soon, however I want to check with upstream first to see if there
is something we might be overlooking or not first.  ie:  Why are they
not this way already by default?  If upstream integrates the changes, or
if there are no major reasons why these changes would be considered very
wrong, I'll integrate them.

I'll update the report once I hear back...
Comment 7 Mark J. Cox (Product Security) 2003-04-23 10:06:31 EDT
Mike, did this get fixed in 8.0 or 9?
Comment 8 Mike A. Harris 2003-04-23 13:31:07 EDT
No, still open.
Comment 9 Josh Bressers 2004-06-18 16:33:34 EDT
Mike, does this issue still apply to anything we ship?
Comment 10 Josh Bressers 2004-06-18 16:34:13 EDT
Add myself to the CC list.
Comment 14 Mike A. Harris 2005-04-10 19:38:59 EDT
Filed in upstream bugzilla for review and consideration for X11R7:

https://bugs.freedesktop.org/show_bug.cgi?id=2959
Comment 15 Mike A. Harris 2005-04-10 20:28:45 EDT
I've created a new unified diff containing all changes, as well as
Imakefile changes, and submitted it in the upstream bug report filed
above.  We will track this issue in the X.Org bugzilla now.

Setting status to UPSTREAM.
Comment 16 Mike A. Harris 2006-07-21 17:46:10 EDT
Resolved in CVS head a while ago according to the upstream bug report...


Note You need to log in before you can comment on or make changes to this bug.