Bug 209024 - X doesn't come up in proper resolution for LCD
Summary: X doesn't come up in proper resolution for LCD
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-03 00:39 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 21:52:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x log file (64.44 KB, text/plain)
2006-10-03 00:39 UTC, Jeremy Katz
no flags Details
T42 problematic X log file (59.02 KB, text/plain)
2006-10-24 05:50 UTC, Thomas M Steenholdt
no flags Details

Description Jeremy Katz 2006-10-03 00:39:40 UTC
I'm not getting X coming up in the proper resolution on my desktop box at home
with a Radeon X300SE.  Attached via DVI to an LCD (1280x1024) and all I'm
getting with the stock X config is 800x600.  Log file attached.

Comment 1 Jeremy Katz 2006-10-03 00:39:40 UTC
Created attachment 137614 [details]
x log file

Comment 2 Jeremy Katz 2006-10-03 00:43:36 UTC
Using the radeon option "DDCMode" "on" seems to cause it to DTRT...

Comment 3 Adam Jackson 2006-10-03 16:21:18 UTC
You're using xorg-x11-drv-ati < 6.6.2-4, aren't you.

Comment 4 Jeremy Katz 2006-10-03 17:26:59 UTC
I'm 99% sure that I grabbed -4 to try last night -- I can double check when I
get home

Comment 5 Jeremy Katz 2006-10-04 20:37:38 UTC
Yep, definitely have -4 and need the option in the config

Comment 6 Thomas M Steenholdt 2006-10-24 05:47:07 UTC
I believe i'm seing the same problem in a slightly different incarnation.
I'm on 6.6.2-4 too, but running on an IBM ThinkPad T42 with a ATI Technologies
Inc RV350 [Mobility Radeon 9600 M10].

If doing a clean boot all the way to X, the resolution is fine. Any later
restarts of X, logout, runlevel changes etc. that would cause X to restart
triggers the problem for me and I also end in 800x600.

option "DDCMode" "on" does not work around this problem for me.

But i checked the Xorg.0.log file for interesting info and it looks like X for
some reason believes that I have an external monitor connected to the system
(which I don't - for the sake of clarity :o)). But since there really is no
monitor, practically all usable resolutions are "out of range" and we end in
800x600.

To let X know that i really have no external monitor connected, I added:

option "MonitorLayout" "LVDS, NONE"

to xorg.conf and problem is now successfully worked around.

Comment 7 Thomas M Steenholdt 2006-10-24 05:50:02 UTC
Created attachment 139194 [details]
T42 problematic X log file

Comment 8 Thomas M Steenholdt 2006-10-24 05:54:13 UTC
Both Jeremy's and my own log file have :

(WW) RADEON(0): Failed to detect secondary monitor DDC, default HSync and
VRefresh used

The problem is further that this faulty detection is used to find a common mode
for MergedFB - leaving us in 800x600.

Comment 9 Adam Jackson 2007-07-27 21:42:31 UTC
Jeremy, have you seen this recently?


Note You need to log in before you can comment on or make changes to this bug.