Bug 209031 - eclipse 3.1.2 consumes all memory
eclipse 3.1.2 consumes all memory
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 22:02 EDT by Nathanael Noblet
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 03:20:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 27031 None None None Never

  None (edit)
Description Nathanael Noblet 2006-10-02 22:02:49 EDT
Description of problem:
starting eclipse consumes all available RAM an slows a machine down until killed

Version-Release number of selected component (if applicable):
3.1.2

How reproducible:
Not it is random as far as observed

Steps to Reproduce:
1. Start eclipse
2.
3.
  
Actual results:
splashscreen opens
classes are loaded to a random point and then RAM is consumed, eclipse no longer
responds, and the process must be killed (which is difficult with a nearly
non-responsive machine)

Expected results:
program opens

Additional info:
I have had this with various plugins installed phpeclipse, pydev, wst/wtp
Comment 1 Ben Konrath 2006-10-02 23:11:12 EDT
What architecture are you using?
Comment 2 Nathanael Noblet 2006-10-03 02:53:58 EDT
x86_64
Comment 3 Ben Konrath 2006-10-04 00:57:34 EDT
I had this problem on one of my i386 machines as well but it seemed to be
machine dependent because another box I had didn't have this problem. 

Are you planning to upgrade to FC6? If so, I'd like to know how things go with
that release. If it's still broken in FC6, I'll track down the machine that had
the problem with FC5 and see if I can reproduce it as well. Thanks.
Comment 4 Nathanael Noblet 2006-10-04 15:50:36 EDT
Just downloaded FC6-pre DVD ISO images. Did an upgrade. Had a few package
problems (I had the livna repo enabled previously and X wouldn't start because I
had the nvidia driver installed as well). Once I got all that cleaned up. Logged
in. Started a few apps (evolution,gaim,banshee). Then started eclipse. First
time start, and it started to eat ram. It ended up consuming 1GB of physical ram
and 1G of swap before I finally killed it, I say finally because machine
response was obviously very slow.
Comment 5 Nathanael Noblet 2006-10-12 01:14:27 EDT
I've done a clean re-install of eclipse about 3 times, removing it and all
dependancies, eclipse-*, ant, tomcat libswt3-gtk, rm -rf /usr/share/eclipse. I
have a couple plugins installed phpeclipse, phpide and pydev, plus their
dependancies. I haven't been using eclipse much of late the last few days.
Tonight I was going to start a python project. Starting ecplise started to
consume all the memory again. Is there anyway I can strace it or something to
provide more info? I'm not so well versed with tracing java issues. Just let me
know.
Comment 6 Ben Konrath 2006-10-12 15:33:55 EDT
This is really a GCJ problem. Tom Fitzsimmons said he would help you get started
profiling this. Thanks Tom.
Comment 7 Thomas Fitzsimmons 2006-10-12 16:51:53 EDT
Nathanael, install the gcc-debuginfo package using yum.  Then you can use
oprofile to collect and display profiling data.

First run eclipse as you normally would.  Then as root, run:

opcontrol --start --no-vmlinux

wait a minute or so, then run:

opcontrol --stop

and post the result of:

opreport --symbols

here.  You may need to install the debuginfo from other relevant packages too,
but you don't need to recollect the profiling data again; installing more
debuginfo will only make the opreport output more meaningful.
Comment 8 Nathanael Noblet 2006-10-12 20:36:58 EDT
Is this to be done when there is a problem, or when it is working correctly?
Comment 9 Thomas Fitzsimmons 2006-10-12 20:39:08 EDT
When there is a problem.
Comment 10 Jakub Jelinek 2007-07-03 03:20:43 EDT
FC5 is no longer supported and the requested oprofile data hasn't been supplied
either.  If you can reproduce this in F7 or on rawhide, please reopen with
the requested data.

Note You need to log in before you can comment on or make changes to this bug.