Bug 209036 - Install locks at installing inn - 8 minutes to go to finish
Install locks at installing inn - 8 minutes to go to finish
Status: CLOSED DUPLICATE of bug 210072
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 22:20 EDT by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 17:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The installation log up to the failure (49.19 KB, text/plain)
2006-10-02 22:20 EDT, Jim Cornette
no flags Details
Mesages from partial install (49.52 KB, text/plain)
2006-10-02 22:25 EDT, Jim Cornette
no flags Details
dmesg from partial system (19.36 KB, text/plain)
2006-10-02 22:26 EDT, Jim Cornette
no flags Details
The REAL install log (38.24 KB, text/plain)
2006-10-02 22:36 EDT, Jim Cornette
no flags Details
This is the install syslog (38.24 KB, text/plain)
2006-10-02 22:42 EDT, Jim Cornette
no flags Details
dmesg from the installer system when stopped at inn (16.00 KB, text/plain)
2006-10-04 23:00 EDT, Jim Cornette
no flags Details
This is a top output when stopped at inn (3.96 KB, text/plain)
2006-10-04 23:02 EDT, Jim Cornette
no flags Details
Install log from secongd installation attempt. (43.12 KB, text/plain)
2006-10-04 23:05 EDT, Jim Cornette
no flags Details
Install.log.syslog for system. (5.86 KB, text/plain)
2006-10-04 23:09 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2006-10-02 22:20:18 EDT
Description of problem:
I could not perform a GUI install because the MGA driver makes the monitor go
out of range. I had to do a text install.
The text install had package selections that did not match the selected groups.
This made package selection only possible because of familiarity with what was
in these particular groups.
The text installer hung with only 8 minutes to finish on a package named inn.

Version-Release number of selected component (if applicable):

version on FC6-pre installation DVD.
How reproducible:


Steps to Reproduce:
1. run linux text
2. select custom partitioning scheme and give mountpoints
3. select packages desired as best as I could
4. Allow installer to format disks selected and to install packages.
5. Notice inn was taking a long time and never seemed to get any further through
the install.
6. Chroot to /mnt/sysimage and look around in tty2. was able to start
networking, launch mc read files that were installed. Was able to run
/sbin/grub/install /dev/hdb1 manually.
7. reboot computer, the install is incomplete.
  
Actual results:
I was able to boot into the installation after the install attempt using the
boot partition from the working install. I could not login as root, so I booted
to runlevel 1. I tried to change the password for root, thinking that I forgot
the password that I applied. I could not change the password because passwd
would kick me out with an authentication error. I was able to create a regular
user and assign a password for the regular user,

Expected results:
A working GUI. Menus for the package groups matching the subgroup selection.
Either successfully installing inn or timing out and giving me the chance to
continue with the installation, skipping or retrying the installation of inn.

Additional info:

Posted a brief message on the test list.
Comment 1 Jim Cornette 2006-10-02 22:20:19 EDT
Created attachment 137617 [details]
The installation log up to the failure
Comment 2 Jim Cornette 2006-10-02 22:25:01 EDT
Created attachment 137618 [details]
Mesages from partial install

This may not be of much value. The system was sort of bootable
Comment 3 Jim Cornette 2006-10-02 22:26:30 EDT
Created attachment 137619 [details]
dmesg from partial system

I could not start network either
Comment 4 Jim Cornette 2006-10-02 22:36:29 EDT
Created attachment 137620 [details]
The REAL install log

Since I am copying files from the failed install on the working system, the
paths are relative to where I mounted the files. The first attached log is from
this working install. This is from the failed install.
Bug reporters have bugs too - :-)
Comment 5 Jim Cornette 2006-10-02 22:42:28 EDT
Created attachment 137621 [details]
This is the install syslog

This the other install file put into /root on the failed installation.
Comment 6 Jeremy Katz 2006-10-04 11:38:27 EDT
Were there any error messages on other ttys when it hung?
Comment 7 Jim Cornette 2006-10-04 20:45:22 EDT
I don't recall any out of the ordinary messages on any of the screens. I am
about to try this again and will pay closer attention to the screen messages.
Even though I did not intentionally choose inn or xen, both were installed.
Anaconda just seemed unresponsive.

I'll add to the report if I find any useful information on attempt 2.
Comment 8 Jim Cornette 2006-10-04 22:57:40 EDT
I tried again and inn just seemed to stall with 87% inmstall completed and 14
minutes to go this time. The only abnormality that I saw was an error related to
the floppy.
I chrooted to /mnt/sysimage and ran ps -A, top, free and various processes. I
also dived into the inn rpm to see if it was possibly corrupted. I had no
problem peering into the rpm. I did not poke around a lot in the rpm.
I will attach the ps -A processes captured from my chroot. I noticed two
instances of anaconda running. One instance was not run from tty1 the other was.
Anyway, I'll start with the attachments. They should be more helpful than my
explanation attempt.
Comment 9 Jim Cornette 2006-10-04 23:00:29 EDT
Created attachment 137794 [details]
dmesg from the installer system when stopped at inn
Comment 10 Jim Cornette 2006-10-04 23:02:02 EDT
Created attachment 137795 [details]
This is a top output when stopped at inn
Comment 11 Jim Cornette 2006-10-04 23:05:33 EDT
Created attachment 137796 [details]
Install log from secongd installation attempt.
Comment 12 Jim Cornette 2006-10-04 23:09:44 EDT
Created attachment 137797 [details]
Install.log.syslog for system.

This is probably a hybrid message which has the installer and the actions that
I performed in the chrooted system that was partially installed.

Last of attachment series for now.
Comment 13 Jeremy Katz 2006-10-05 10:52:34 EDT
How much memory does this system have?
Comment 14 Jim Cornette 2006-10-05 21:21:48 EDT
256 MB - I am currently running on the system using the 87% install and there
are two notable problems. The first being that I cannot change the password for
root or do not see grub related config files. I was able to go to runlevel 1,
activate the network, launch my user created during the inn pause with success.
I cannot do anything that needs root access in anything other than runlevel 1.
I guess 256 MB would have been sufficient information.

 free
             total       used       free     shared    buffers     cached
Mem:        252632     248792       3840          0       1844      62636
-/+ buffers/cache:     184312      68320
Swap:      1024744      11216    1013528
Comment 15 Jeremy Katz 2006-10-05 23:22:04 EDT
Okay, this makes three reporters seeing similar things with 256 megs of RAM. 
And I managed to reproduce today in a Xen guest.  Time to do some serious
debugging :-)
Comment 16 Jim Cornette 2006-10-05 23:33:11 EDT
Thanks.
Comment 17 Jeremy Katz 2006-10-09 17:00:35 EDT

*** This bug has been marked as a duplicate of 210072 ***

Note You need to log in before you can comment on or make changes to this bug.