Bug 2090807 - KDE desktop redraws weirdly when moving mouse.
Summary: KDE desktop redraws weirdly when moving mouse.
Keywords:
Status: CLOSED DUPLICATE of bug 2088644
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: BetaBlocker, F37BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2022-05-26 15:13 UTC by Lukas Ruzicka
Modified: 2022-08-03 16:30 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-03 16:30:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Ruzicka 2022-05-26 15:13:20 UTC
Description of problem:

When moving mouse in the KDE desktop, parts of the display flicker while the desktop keeps redrawing. That causes situations when you want to click on something and it temporarily becomes black and you need to wait 500 - 1000 miliseconds for it to appear.

I spotted this in a freshly installed virtual machine.

Version-Release number of selected component (if applicable):
KDE 5.24.5

How reproducible:
Always

Steps to Reproduce:
1. Install latest KDE iso (20220525).
2. Try to run applications and use them.
3. You will see.

Actual results:

Flickering and incorrect redrawal of the display.

Expected results:

Stable display.

Comment 1 Lukas Ruzicka 2022-05-27 08:13:13 UTC
Created attachment 1884045 [details]
The way how the VM behaves.

Comment 2 Fedora Blocker Bugs Application 2022-05-27 12:28:58 UTC
Proposed as a Blocker for 37-beta by Fedora user lruzicka using the blocker tracking app because:

 I am not sure, but I would think that the described behaviour breaks the basic functionality of a DE, when it is difficult to use it because of flickering here and there.

Comment 3 Adam Williamson 2022-05-27 15:46:00 UTC
Is this with mesa-22.1.0-1.fc37 ? if so, probably a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=2088644 . Try with any newer mesa build than that.

Comment 4 Adam Williamson 2022-07-20 16:59:40 UTC
Ping Lukas, can you check this?

Comment 5 Lukas Ruzicka 2022-08-03 08:06:56 UTC
Hello Adam,

sorry for the late reaction, but the needinfo notification seems to have fallen into the depth of the Bugzilla folder without me noticing it.
I have tried with the latest compose and I **do not** see the issue any longer, so the issue must have been addressed already.

Comment 6 Adam Williamson 2022-08-03 16:30:39 UTC
Probably was a dupe of 2088644 then. Thanks!

*** This bug has been marked as a duplicate of bug 2088644 ***


Note You need to log in before you can comment on or make changes to this bug.