Bug 209103 - Problem with install RHEL on IBM HS20 + FC Storage (EMC)
Problem with install RHEL on IBM HS20 + FC Storage (EMC)
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 04:23 EDT by Andrzej Nakonieczny
Modified: 2008-10-01 15:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 15:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug file from anaconda (155.14 KB, text/plain)
2006-10-03 04:23 EDT, Andrzej Nakonieczny
no flags Details

  None (edit)
Description Andrzej Nakonieczny 2006-10-03 04:23:05 EDT
Description of problem:
In time of installation anaconda gets different execptions

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 4.91 (Tikanga)

How reproducible:
IBM HS20 + FC Storage with multipath

Steps to Reproduce:
1. Try to install RHEL
2.
3.
  
Actual results:
Anaconda gets different exceptions like "device or resource busy" or "no such 
device", sometimes not.

Expected results:
No anaconda's exception.

Additional info:
In addatched files
Comment 1 Andrzej Nakonieczny 2006-10-03 04:23:06 EDT
Created attachment 137630 [details]
debug file from anaconda
Comment 2 Andrzej Nakonieczny 2006-10-05 17:48:00 EDT
I looked for similar bugs like my and I found #201235. I see that it's closed 
now. I tried to replace part of anaconda to check if it helps in my situation. 
I got new version of dmraid.py from CVS (revision 1.19) and I replaced this one 
in minstg2.img and stage2.img. Now installer goes on but can't see multipath 
device. I don't know why but now anaconda try to access direct storage devices 
like sda, sdb, sdc and sdd (all these devices are the same one hardware disk on 
emc storage but sees trough different fc path). Two from these devices are 
unaccesable (sdb and sdd if I remember correctly) what's alerted by anaconda. 
If I choose (in anacodna's window box) to ignore these errors anaconda goes on 
and system is installed. But there still is something wrong because disk seems 
to be empty. On the end of installation grub failed on root hd(0,0) command. I 
switched to text console and I tried to list content of disk but it looks 
empty. There is not any partition even though these partitions are mounted. 
It's very strange. In /proc/partitions I can see sda disk with 2 partitions 
(sda1 and sda2) but fdisk or parted shows empty list. I tried to run partprobe 
(in chroot on /mnt/sysimages) to refresh partition table but without results. 
It's look like something is erased existing partition in time of installation. 
Is it possible? After boot again from cdrom in rescue mode I can't see anything 
on that disk. Any ideas?
Comment 3 Chris Lumens 2008-04-18 07:02:24 EDT
Is this still a problem in 5.1?  I know a lot of work went into storage there so
this could be fixed up.
Comment 4 Andrzej Nakonieczny 2008-04-19 12:27:15 EDT
(In reply to comment #3)
> Is this still a problem in 5.1?  I know a lot of work went into storage there so
> this could be fixed up.

No, it doesn't if you add 'mpath' to boot parameters before install. But if I
remeber correctly the same problem still exists when you install on FC storage
with multipath and multiple disks defined. Now I haven't time to check it again
so when I have to install a new system I'm adding only one disk (still with
multipath) and after installation I adding next one.

Note You need to log in before you can comment on or make changes to this bug.