Bug 20913 - "Invalid server certificate" error caused up2date to crash
"Invalid server certificate" error caused up2date to crash
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2000-11-15 12:36 EST by Panic
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-11-17 10:08:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Panic 2000-11-15 12:36:09 EST
Original up2date (stock 7 installation, not the respin).  I selected all
the available packages, including glibc 2.1.94-3.  Just after I installed
the glibc package, but before any other packages were installed, the
up2date program crashed with this error in the terminal window I started it

Traceback (innermost last):
  File "/usr/share/rhn/up2date/gui.py", line 475, in doInstallation
    up2date.installPackages(self.selectedPkgList, self.rpmCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 1037, in installPackages
    rc = ts.run(0, 0, rpmCallback, cfg.readEntry("storageDir"))
  File "/usr/share/rhn/up2date/gui.py", line 458, in rpmCallback
    up2date.remoteDelPackage((name, version, release, epoch))
  File "/usr/share/rhn/up2date/up2date.py", line 632, in remoteDelPackage
    raise CommunicationError(f.faultString)
up2date.CommunicationError: Error communicating with server.  The message was:
Invalid server certificate

Note that this was *after* glibc installed, and before anything else.  I
marked this low-priority since glibc is excluded by default from the normal
up2date update sequence.  However, on another system I updated only glibc
(worked), then ran through the client again for the rest of the packages
(worked).  It is also low priority because I've been unable to reproduce
this on a test system -- I just wanted to get it in the database for future

Comment 1 Chris Eaton 2000-11-17 10:08:53 EST
I'm having the same problem with up2date, although it wasn't in the middle of installing anything. All of the sudden a few days ago it stopped working with the "Invalid Server Certificiate" error.

Going to the server it goes to in Opera results in the same error, there is some kind of a problem with the server's SSL Certificiate.

With that in mind, its not really a RH7, but a Redhat.com server problem. It would be really nice to have a fix though, as it makes up2date completely useless.
Comment 2 Preston Brown 2000-11-28 11:52:01 EST
this was a transient server issue that has been corrected.  Please re-open if
the problem persists.

Note You need to log in before you can comment on or make changes to this bug.