Bug 2091484 - luarocks package should pull in lua-devel as a dependency
Summary: luarocks package should pull in lua-devel as a dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: luarocks
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Lind
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-30 05:24 UTC by "FeRD" (Frank Dana)
Modified: 2022-10-04 02:06 UTC (History)
3 users (show)

Fixed In Version: luarocks-3.9.1-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-04 02:06:23 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description "FeRD" (Frank Dana) 2022-05-30 05:24:54 UTC
Description of problem:
A new Fedora user reported[1] problems using luarocks after install, because it failed to compile a module after downloading it. The user eventually worked out on their own that they needed to install lua-devel, but they shouldn't have had to puzzle that solution out. By its very nature, luarocks needs to have the lua headers available for it to function properly. It should pull in lua-devel as a dependency automatically when installed.

Version-Release number of selected component (if applicable):
luarocks-3.7.0-3.fc35.noarch


How reproducible:
100%

Steps to Reproduce:
1. sudo dnf install luarocks
2. luarocks install --local lcurses
3.

Actual results:
"Error: Failed finding Lua header files. You may need to install them or configure LUA_INCDIR."

Expected results:
Package compiles successfully

Additional info:

[1]: https://ask.fedoraproject.org/t/problem-using-luarocks-on-f35/22897

Comment 1 "FeRD" (Frank Dana) 2022-05-30 05:43:40 UTC
In fact, the luarocks package seems to be missing a LOT of dependencies.

It has build backends for both cmake and make, but pulls in neither of them as a dependency. It also needs a C/C++ compiler, potentially, but has no such need expressed in its package dependencies. User systems can't be assumed to all have these tools available.

Comment 2 "FeRD" (Frank Dana) 2022-05-30 07:11:26 UTC
(In reply to "FeRD" (Frank Dana) from comment #1)
> It also needs a C/C++ compiler, potentially

In fact, not just potentially. The lua module /usr/share/lua/5.4/luarocks/core/cfg.lua uses the `gcc` command, specifically, as part of its configuration probing, so it _DEFINITELY_ needs to have a runtime dependency on `gcc`.

Comment 3 Ben Cotton 2022-08-09 13:17:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 4 Fedora Update System 2022-10-04 02:02:22 UTC
FEDORA-2022-9a29de14da has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-9a29de14da

Comment 5 Fedora Update System 2022-10-04 02:06:23 UTC
FEDORA-2022-9a29de14da has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.