Bug 209202 - Multisession DVDs produced by growisofs cannot be mounted on an IDE drive
Multisession DVDs produced by growisofs cannot be mounted on an IDE drive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity low
: ---
: ---
Assigned To: Aristeu Rozanski
Brian Brock
:
: 209200 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 16:54 EDT by Need Real Name
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.9-55.EL
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 16:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-10-03 16:54:56 EDT
Description of problem:
Multisession DVDs produced by growisofs cannot be mounted on an IDE drive 
because of a kernel bug. The same DVDs can be mounted when the IDE drive is in 
ide-scsi emulation. Please fix this.

Version-Release number of selected component (if applicable):
Everything (afaik).

How reproducible:
Some documentation is found in /usr/share/doc/dvd+rw-tools-5.21.4.10.8-
4/index.html...

"Linux kernel 2.6 users might experience ... http://marc.theaimsgroup.com/?
l=linux-kernel&m=108827602322464&w=2 ... problems
mounting multi-session media with last session starting beyond
2.2GB boundary. As fast-acting remedy I can suggest to route your unit
through ide-scsi. The way it was under 2.4. Even though it's declared
unsupported it actually still works in 2.6 (I for one still use it)."

Steps to Reproduce:
1. Burn a DVD with over 2GB of data (growisofs -Z /dev/cdrom ...)
2. Add data (growisofs -M /dev/cdrom)
3. Attempt to mount to see the error (mount is successful with ide-scsi kernel 
parameter).
  
Actual results:
[root@devoi ~]# mount /dev/hdb /cdrom
mount: block device /dev/hdb is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdb,
       or too many mounted file systems

Additional info:
I am running this test from a supported system; the system ID is: ID-1006241967.
Comment 1 Jason Baron 2007-02-09 16:45:41 EST
*** Bug 209200 has been marked as a duplicate of this bug. ***
Comment 2 Aristeu Rozanski 2007-05-22 10:13:14 EDT
I wasn't able to reproduce this with the latest RHEL-4 kernel. Can you confirm if
this problem still exists in 4.5 kernel?
Thanks
Comment 3 Need Real Name 2007-05-30 15:47:47 EDT
Yes, this seems to be fixed using the 2.6.9-55.ELsmp kernel.
Comment 4 Aristeu Rozanski 2007-05-30 16:09:43 EDT
Good. I'll close this ticket, but feel free to reopen if you manage to reproduce
it again.

Note You need to log in before you can comment on or make changes to this bug.