Bug 209243 - anaconda crash in network_text.py starting install
anaconda crash in network_text.py starting install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 21:30 EDT by Mark Smith
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 00:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (36.41 KB, text/plain)
2006-10-03 21:30 EDT, Mark Smith
no flags Details

  None (edit)
Description Mark Smith 2006-10-03 21:30:12 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Oct3 snapshot of rawhide

How reproducible: easy


Steps to Reproduce:
1. netboot ppc64 system with rawhide ppc64.img (Oct 3 version)
text install mode
power5 system has Veth for eth0, Vscsi client disks: sda, sdb
configure eth0 as static and point to nfs://rhlte/distros/rawhide_snap/ dir
2. anaconda will start. accept default partitioning offered (doesn't seem to
matter).
3. when eth0 config menu is offered, accept defaults offered (is same as when i
config'd it to start the nfs install):
dhcp: not selected
ipv4: selected
ipv6: not selected
activate on boot: selected
correct static ip and netmask are offered.
click ok and anaconda crashes.
  
Actual results:
cannot install

Expected results:
successful install

Additional info:
I will attach the traceback
Traceback (most recent call first):
  File "/usr/lib/anaconda/textw/network_text.py", line 387, in runScreen
    self.handleBroadCastError()
  File "/usr/lib/anaconda/textw/network_text.py", line 434, in __call__
    showonboot)
  File "/usr/lib/anaconda/text.py", line 517, in run
    rc = win(self.screen, instance)
  File "/usr/bin/anaconda", line 956, in ?
    anaconda.intf.run(anaconda)
AttributeError: NetworkDeviceWindow instance has no attribute 'handleBroadCastError'
Comment 1 Mark Smith 2006-10-03 21:30:12 EDT
Created attachment 137715 [details]
traceback
Comment 2 David Cantrell 2006-10-04 00:01:12 EDT
I committed a fix for this earlier today.  I discovered I had forgotten to
define the handleBroadCastError() function in network_text.py (did the ipv6
changes in network_gui.py first), and that was getting called because the
network and broadcast address calculation was failing on big endian systems. 
Also fixed that today.

A new anaconda was submitted for building at the end of the workday on Oct 3, so
the fixes should be present in the Oct 4 tree composition for rawhide.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.