Bug 209249 - [packaging bug] out of order compilation of source files for ecj
Summary: [packaging bug] out of order compilation of source files for ecj
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 209147
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-04 02:09 UTC by Ben Konrath
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.2.1-23.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 19:21:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Konrath 2006-10-04 02:09:58 UTC
+++ This bug was initially created as a clone of Bug #209147 +++

apologies for the length of this report.

I recently tried to "rpmbuild --rebuild" all of RHEL4 (AS) from source.

to speed things up, I activated swap on a large file (~ 6 GB), and then mounted
/usr/src/redhat/BUILD as a 5 GB tmpfs.  since my RAM was rather large (~
512 MB), that ensured that building most small packages only involved
I/O within RAM, and did not even touch the platters, because the build
directory was deleted after successful builds: much faster than
building with /usr/src/redhat/BUILD living in a "real" file system.

most packages built fine.  an exception was ecj, that kept failing with
the attached log.  it took me awhile to understand where the problem is,
and it became clear only after I successfully built in a real file system,
and discovered that the same specfile
- in a tmpfs, tries to compile QualifiedAllocationExpression.java BEFORE
  TypeReference.java, and therefore fails
- in a real file system, compiles TypeReference.java first, and all the
  rest goes smoothly.

the core of the problem is the fact is that the find utility (used in
your spec-file) does not guarantee any order in its output: it follows
the order of entries in the directory it is visiting.

without knowing the details of the tmpfs implementation in Linux, I
guess that while in most real file systems directories are almost linear, and
the order is the same as when files were extracted from the source file
to the directory, in the tmpfs the order is random (maybe the directory
is represented by a tree and traversed in pre- or post-order).

whatever the reason, ecj might fail to build somewhere else, if directory 
layout has not an intrinsic order.  perhaps the spec-file should order source
files a priori.

-- Additional comment from g.bonacci@pisa.iol.it on 2006-10-03 11:55 EST --
Created an attachment (id=137661)
failed build (compressed log file)

Comment 1 Ben Konrath 2006-12-06 19:21:17 UTC
This is fixed in FC-6 updates (3.2.1-23.fc6) and rawhide.


Note You need to log in before you can comment on or make changes to this bug.