Bug 209264 - Review Request: emerald-themes - Themes for Emerald, the window decorator for Beryl
Review Request: emerald-themes - Themes for Emerald, the window decorator for...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michał Bentkowski
Fedora Package Reviews List
:
Depends On: 209259
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2006-10-04 02:31 EDT by Jarod Wilson
Modified: 2011-04-05 11:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 15:58:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2006-10-04 02:31:00 EDT
Spec URL: http://wilsonet.com/packages/beryl/emerald-themes.spec
SRPM URL: http://wilsonet.com/packages/beryl/emerald-themes-0.1.0-1.fc6.src.rpm
Description:
--
Emerald is themeable window decorator and compositing 
manager for Beryl. Launch Theme Manager from
beryl-manager to change themes.

This package contains themes for emerald.
--

NOTE: This package depends on beryl-core, under review here: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=209259, as well as emerald, under review here: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=209263.
Comment 1 Jarod Wilson 2006-10-26 11:45:16 EDT
Just pushed a 0.1.1 build out:

http://wilsonet.com/packages/beryl/emerald-themes-0.1.1-1.fc6.src.rpm
Comment 2 Martin Sourada 2006-11-14 12:55:02 EST
You should fix this rpmlint output:
E: emerald-themes non-executable-script /usr/share/emerald/themes/import.sh 0644
Comment 3 Jarod Wilson 2006-11-14 14:18:00 EST
(In reply to comment #2)
> You should fix this rpmlint output:
> E: emerald-themes non-executable-script /usr/share/emerald/themes/import.sh 0644
> 

I've removed it from the package entirely, its only needed at build time. That
change, plus the switch to the upstream tarball are in the latest build:

http://wilsonet.com/packages/beryl/emerald-themes-0.1.2-2.fc6.src.rpm
Comment 4 Michał Bentkowski 2006-11-16 10:00:31 EST
MUST items:
 * rpmlint is quiet
 * package is named well
 * spec file name is good
 * package meets Packaging Guidelines
 * package is licensed with a GPL open-source compatible license 
 * License field in spec file matches actual license
 * license file is included in %doc
 * md5sums are matching (c5aa35e30d3476f05a469f1baac16341)
 * package successfully compiles on x86_64
 * BuildRequires listed well
 * no locales
 * no need to %post and %postun sections
 * not relocatable
 * package owns directories well
 * no duplicates in %files
 * every %files section includes %defattr
 * proper %clean section
 * macros used well

This package is obviosly approved :)
Comment 5 Jarod Wilson 2006-11-16 10:43:13 EST
Imported and built for devel, FC6 branch requested.
Comment 6 leigh scott 2011-04-04 19:29:19 EDT
Package Change Request
======================
Package Name: emerald-themes
New Branches: el6
Owners: leigh123linux
Comment 7 Jason Tibbitts 2011-04-05 11:17:42 EDT
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.