Bug 209266 - Please add lvm_tab to /etc/init.d/netfs script
Please add lvm_tab to /etc/init.d/netfs script
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 02:42 EDT by Lior Kaplan
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 15:04:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lior Kaplan 2006-10-04 02:42:08 EDT
Summery:
/etc/init.d/netfs scripts will activate all the VGs in the system by the command
'vgchange -ay'. There is no way to configure VGs not to activate.

More info:
I'd like this feature due to a Cluster I have, with two server sharing a disk. I
want don't want the VGs to be activated at the system startup. I prefer the
cluster daemon (Service Guard in my case) to do the activation on one of the nodes.

For that I need a way to have the init scripts read some config file
(/etc/lvm/lvmtab ?) for the list of VGs to activate.

I've tried using the option for this in /etc/lvm/lvm.conf, but that option
disables the use of the VG until the file is edited again.

Thanks
Comment 1 Bill Nottingham 2006-10-04 11:49:42 EDT
This is the same command that's in rc.sysinit - I'm not sure there's a
particular simple change that could solve this.

Long term, you'd probably want a storage daemon that listens to storage hotplug
events and then knows what LVs, VGs, etc. to activate, but that's a long ways off.
Comment 2 Bill Nottingham 2007-09-28 15:04:45 EDT
With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. There's really not a good way to fix this simply.

Note You need to log in before you can comment on or make changes to this bug.