Bug 209272 - "Select Thread" doesn't actually select the thread
"Select Thread" doesn't actually select the thread
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 03:40 EDT by Nicholas Miell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 12:22:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 216485 None None None Never
GNOME Desktop 262224 None None None Never

  None (edit)
Description Nicholas Miell 2006-10-04 03:40:58 EDT
Description of problem:
If you do Folder -> Select Thread in Evolution, the thread(s) containing the
currently selected message(s) aren't selected.

This upstream maintainer (fejj) is crazy and won't fix this.

Version-Release number of selected component (if applicable):
All of them.

How reproducible:
Always.

Steps to Reproduce:
1. Press Ctrl-H or select Folder -> Select Thread
  
Actual results:
Some weird collection of messages is selected instead of an actual thread.

Expected results:
The actual thread is selected.

Additional info:
Upstream bug is at http://bugzilla.gnome.org/show_bug.cgi?id=216485
Current fix is: http://bugzilla.gnome.org/attachment.cgi?id=61803
(Note that this patch requires l10n effort.)
Comment 1 David Woodhouse 2006-10-04 04:06:16 EDT
I've added this to my private builds of evo, which also fix bug 187565 (6 months
old, crash) and bug 167805 (13 months old; actually reported elsewhere even
longer ago, severe usability).

It'll be in evolution-2.8.0-7.fc6.dwmw2.2 when that appears later today in my
repo at ftp://ftp.infradead.org/pub/dwmw2-fc6/
Comment 2 Matthew Barnes 2006-10-04 05:15:37 EDT
I agree that the current behavior is misleading.  I've re-raised the issue
upstream to get a second opinion from the current maintainers.

http://bugzilla.gnome.org/show_bug.cgi?id=359529
Comment 3 Matthew Barnes 2006-10-04 13:50:29 EDT
It looks like this has been taken care for Evolution 2.9.

http://bugzilla.gnome.org/show_bug.cgi?id=262224
Comment 4 Matthew Barnes 2007-01-02 12:22:25 EST
Closing as UPSTREAM since there is an equivalent bug report upstream.  I will
continue to track the problem there.  Please refer to [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=262224

Upstream developer claimed to have a patch ready for 2.9, but it doesn't look
like it was ever committed.

Note You need to log in before you can comment on or make changes to this bug.