Bug 209276 - Error in system-config-cluster version 1.0.27 with IPMI fence device
Error in system-config-cluster version 1.0.27 with IPMI fence device
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 05:03 EDT by Jose Plans
Modified: 2016-04-26 21:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 13:53:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch adding the auth field for recognition. (785 bytes, patch)
2006-10-04 05:03 EDT, Jose Plans
no flags Details | Diff

  None (edit)
Description Jose Plans 2006-10-04 05:03:34 EDT
Description of problem:
When configuring a fencing device with auth method different than the default
'none', this one fails. Checking for non-standard (APC, Brocade, McData,
SANBox2..) that won't require just ipaddr, login and passwords fields, the
customer found that ipmi-lan didn't cover auth. 
Following the iLO syntax, they created a patch covering this and seems to work
for them.

Version-Release number of selected component (if applicable):
1.0.27-1.0

How reproducible:
Always

Steps to Reproduce:
1. Configure ipmi-lan fencing with auth MD5 for example.
2. It will fail.
  
Actual results:
Auth field ignored, failure. (XML failed to verify content)

Expected results:
Acceptance of the auth field.

Additional info:
Patch attached.
Comment 1 Jose Plans 2006-10-04 05:03:36 EDT
Created attachment 137725 [details]
Patch adding the auth field for recognition.
Comment 3 Jim Parsons 2006-10-25 18:37:27 EDT
Got it - thanks
Comment 7 Lon Hohberger 2010-01-22 13:53:28 EST
I verified this as fixed in 1.0.54-2.0.  I did not check earlier releases.

Note You need to log in before you can comment on or make changes to this bug.