Bug 209327 - mysql-query-browser segfault on table edit
mysql-query-browser segfault on table edit
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mysql-gui-tools (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-10-04 13:06 EDT by Dawid Zamirski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-11 17:52:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mysql-query-browser gdb output (3.28 KB, text/plain)
2006-10-04 13:06 EDT, Dawid Zamirski
no flags Details

  None (edit)
Description Dawid Zamirski 2006-10-04 13:06:14 EDT
Description of problem:
The mysql-query-browser crashes when I try to edit a table. I have attached gdb
backtrace.

Version-Release number of selected component (if applicable):
mysql-query-browser-1.1.18-4.fc5

How reproducible:
Always

Steps to Reproduce:
1. Start mysql-query-browser
2. Open a databse and right-click on one of its tables
3. Choose "Edit.." and the application crashes
  
Actual results:
** (mysql-query-browser:12858): WARNING **: request for bad widget
'myisam_radio' in glade object
/usr/bin/mysql-query-browser: line 20: 12858 Segmentation fault      $PRG-bin

Expected results:
Show GUI to edit mysql table

Additional info:
mysql-5.0.22-1.FC5.1
mysql-server-5.0.22-1.FC5.1
gtkmm24-devel-2.8.8-1.fc5
gtkmm24-2.8.8-1.fc5
Comment 1 Dawid Zamirski 2006-10-04 13:06:14 EDT
Created attachment 137754 [details]
mysql-query-browser gdb output
Comment 2 Srihari Vijayaraghavan 2006-10-25 07:27:59 EDT
Same here (on both FC5 & FC6 on both x86 & x86-64).
Comment 3 Dennis Gilmore 2007-04-11 11:23:44 EDT
can you please test with the version just pushed.  it has fixed all the bugs 
i've personally seen. 

all the mysql tools are now released as one tarball. so reassigning to the new 
component.
Comment 4 Dawid Zamirski 2007-04-11 17:49:53 EDT
Hi Dennis

I have just checked (on FC6 x86_64, but the same remote MySQL server as in
original report) and it looks like it's  fixed :-) Thank You!

Note You need to log in before you can comment on or make changes to this bug.