Bug 2093513 - file /usr/share/doc/libxslt-devel/EXSLT/devhelp/Makefile conflicts between attempted installs of libxslt-devel-1.1.35-1.fc36.x86_64 and libxslt-devel-1.1.3 5-1.fc36.i686
Summary: file /usr/share/doc/libxslt-devel/EXSLT/devhelp/Makefile conflicts between at...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libxslt
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2081075 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-06-04 01:00 UTC by Hin-Tak Leung
Modified: 2022-07-02 01:19 UTC (History)
5 users (show)

Fixed In Version: libxslt-1.1.35-2.fc36 libxslt-1.1.35-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-20 00:40:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Hin-Tak Leung 2022-06-04 01:00:39 UTC
Description of problem:

Cannot upgrade i686/x64_64 devel packages together:

file /usr/share/doc/libxslt-devel/EXSLT/devhelp/Makefile conflicts between attempted installs of libxslt-devel-1.1.35-1.fc36.x86_64 and libxslt-devel-1.1.3
5-1.fc36.i686

Version-Release number of selected component (if applicable):
libxslt-devel-1.1.35-1.fc36.x86_64
libxslt-devel-1.1.35-1.fc36.i686

How reproducible:
Always

Steps to Reproduce:
1. have 

libxslt-devel-1.1.34-6.fc35.i686
libxslt-devel-1.1.34-6.fc35.x86_64

before upgrade

2. try upgrading

3.

Actual results:
Error above.

Expected results:
Success

Additional info:
erase libxslt-devel-1.1.34-6.fc35.i686 allow it to go forward

Comment 1 Gwyn Ciesla 2022-06-07 15:25:32 UTC
Unfortunately your workaround is the only solution. It should be fixed thereafter.

Comment 2 Hin-Tak Leung 2022-06-07 18:44:27 UTC
The problem is that Makefile is generated from Makefile.in, which is in term generated from Makefile.am . Unfortunately Makefile contains arch-specific references like x86_64 (details below). I think the proper solution is to not ship it in the rpm package.

/usr/share/doc/libxslt-devel/EXSLT/devhelp/Makefile
/usr/share/doc/libxslt-devel/EXSLT/devhelp/Makefile.am
/usr/share/doc/libxslt-devel/EXSLT/devhelp/Makefile.in

There is an earlier report, and similar.
https://bugzilla.redhat.com/show_bug.cgi?id=2081075

# grep x86_  /usr/share/doc/libxslt-devel/EXSLT/devhelp/Makefile
build_triplet = x86_64-redhat-linux-gnu
host_triplet = x86_64-redhat-linux-gnu
LD = /usr/bin/ld -m elf_x86_64
LDFLAGS = -Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1  -Wl,--build-id=sha1 -Wl,-dT,/builddir/build/BUILD/libxslt-1.1.35/.package_note-libxslt-1.1.35-1.fc36.x86_64.ld
PKG_CONFIG = /usr/bin/x86_64-redhat-linux-gnu-pkg-config
build = x86_64-redhat-linux-gnu
build_alias = x86_64-redhat-linux-gnu
build_cpu = x86_64
host = x86_64-redhat-linux-gnu
host_alias = x86_64-redhat-linux-gnu
host_cpu = x86_64

Comment 3 Gwyn Ciesla 2022-06-16 14:38:28 UTC
*** Bug 2081075 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2022-06-16 15:44:53 UTC
FEDORA-2022-14cdccf86b has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-14cdccf86b

Comment 5 Fedora Update System 2022-06-16 15:44:55 UTC
FEDORA-2022-f5d6495a17 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f5d6495a17

Comment 6 Fedora Update System 2022-06-17 01:49:16 UTC
FEDORA-2022-f5d6495a17 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-f5d6495a17`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f5d6495a17

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2022-06-17 02:02:05 UTC
FEDORA-2022-14cdccf86b has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-14cdccf86b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-14cdccf86b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-06-20 00:40:01 UTC
FEDORA-2022-14cdccf86b has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-07-02 01:19:51 UTC
FEDORA-2022-f5d6495a17 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.