Bug 209391 - cursoring behaviour with composed GSUB characters
cursoring behaviour with composed GSUB characters
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
Depends On:
Blocks: 209969
  Show dependency treegraph
 
Reported: 2006-10-04 21:19 EDT by Lawrence Lim
Modified: 2014-03-25 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 05:02:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
test case for oriya locale (414.47 KB, application/octet-stream)
2006-10-04 21:21 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2006-10-04 21:19:15 EDT
Description of problem:
Noticed something interesting on the cursoring, it works ok for GPOS characters
but not GSUB characters like those found in the attached Test Cases.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.4-4.2

How reproducible:
Always

Steps to Reproduce:
1.loaded the Test Case with firefox
2.copy and paste one of the char into oowriter (in my case TC #61)
3.press left arrow key (<-)
  
Actual results:
Cursor still on the right of the character

Expected results:
Should move to the left of the character

Additional info:
Interestingly, after Step 3, try Ctrl-V, the characters will get "mashed"
together. Similar behaviour was not observed in gedit.
Comment 1 Lawrence Lim 2006-10-04 21:21:38 EDT
Created attachment 137790 [details]
test case for oriya locale
Comment 3 Caolan McNamara 2006-10-05 03:52:06 EDT
The last time there was something like this it was a grapheme clustering table
issue, icu/writer is probably still considering the single "character" to be
comprised of separate bits which can be cursored into.
Comment 4 Caolan McNamara 2006-10-05 07:56:45 EDT
Well, this is tricky, but I've added code to icu 3.6-6 which seems to "do the
right thing" for oriya and malayam with respect to such pango-like cursoring
through "foo virama foo" constructs.

Some testing outside the specialized virama using tests of these examples for
normal oriya/malayam text would be "a good thing"(tm)
Comment 6 Caolan McNamara 2006-11-07 12:53:20 EST
*** Bug 213465 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2006-11-07 12:59:06 EST
Strange, I could have *sworn* there was more comments than this in this bug
along the line of "I'm confident it works, but it's not a very elegent solution,
albeit the same as that of pango" and that it was set to modified, and even
maybe verified, closed...

anyway for RHEL-5 we have 3.6-5.5, and all looks well for me there for test case
41 and for other foo virama foo constructs for cursoring through them

Note You need to log in before you can comment on or make changes to this bug.