Bug 209392 - ipw2200 non-functional on Thinkpad T43p
ipw2200 non-functional on Thinkpad T43p
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 21:21 EDT by David Miller
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-13 02:38:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Miller 2006-10-04 21:21:39 EDT
Description of problem:

Although the driver assosciates properly before the interface
is brought up, upon "ifup" the ipw2200 link goes down and
the device becomes totally non-functional.  Even rmmod'ing
the ipw2200 driver and reloading it does not bring the link
back.  Only a full reboot gets the link back, but it again
dies as soon as one tries to ifup the ipw2200 interface.

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1.Boot
2.ifup eth1
3.
  
Actual results:

ipw2200 device wedges

Expected results:

ipw2200 interface comes up properly

Additional info:

I am using the current firmware from Intel's ipw2200 sourceforge
site.  This problem has been happening ever since FC6 post-Test3
rawhide became installable on this laptop.  I do remember FC6 test1
and test2 working with the wireless interface on this system.
Comment 1 David Miller 2006-10-04 21:25:50 EDT
There was one strange message in the kernel logs when the ipw2200 device
tries to come up, from the ieee80211 stack:

eth1: NETDEV_TX_BUSY returned; driver should report queue full via
ieee_device->is_queue_full.

I notice that this debugging message has been removed from the current
ieee80211 stack sources in Linus's GIT tree.
Comment 2 John W. Linville 2006-10-05 08:44:50 EDT
Does it work if you change the ESSID by adding a space on the end?  So for 
example,

   ESSID="davem"

becomes

   ESSID="davem "
Comment 3 David Miller 2006-10-13 02:38:27 EDT
I finally was able to get an install on my laptop using rawhide to start
playing this again, and the problem has gone away.  My wireless works
fine.

I wonder if I had a broken 3.0 firmware image.

Note You need to log in before you can comment on or make changes to this bug.