Bug 2094194 - Log stream paused right after updating log lines in Web Console in OCP4.10
Summary: Log stream paused right after updating log lines in Web Console in OCP4.10
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.10
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.10.z
Assignee: Robb Hamilton
QA Contact: Xiyun Zhao
URL:
Whiteboard:
Depends On: 2091901
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-06-07 05:17 UTC by OpenShift BugZilla Robot
Modified: 2022-07-20 07:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-20 07:46:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 11654 0 None open [release-4.10] Bug 2094194: fix bug where log stream pauses in Chrome 2022-06-18 01:01:19 UTC
Red Hat Product Errata RHBA-2022:5568 0 None None None 2022-07-20 07:46:33 UTC

Comment 4 Xiyun Zhao 2022-07-14 06:48:02 UTC
This bug has been verified on payload 4.10.0-0.nightly-2022-07-13-131411

Verification Env: 
Chrome 103 on macOS Monterey 12.4
Chrome 102 & 103 on Fedora36
Firfox 102 on Fedora36
Edge 103.0.1264.51 on Fedora36

Verification Step:
Steps to Reproduce:
1. Login OCP, go to Workload > Pods (Cluster-version-operator-*) > Logs page
2. Monitor the streaming logs
   - Log stream paused after updating log lines (scroll up)
   - Log stream paused after clicking the "Log stream pauses" button
   - Log is keep streaming after user scrolls down the page
   - Log is keep streaming after user clicks the resume button 
   - Log is keep streaming after user clicks the "Resume stream" blue banner at the bottom of the page

Results:
- Log stream paused automatically after the user scrolls up the page, a blue banner "Resume stream and show XXX lines" will show at the bottom of the page 
- Log stream paused after clicking the button
- Log is keep streaming after user scrolls down the page
- Log is keep streaming after user clicks the resume button 
- Log is keep streaming after user clicks the "Resume stream" blue banner at the bottom of the page

Comment 6 errata-xmlrpc 2022-07-20 07:46:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:5568


Note You need to log in before you can comment on or make changes to this bug.