Bug 209429 - iSCSI root oops on x86_64 xen domU
iSCSI root oops on x86_64 xen domU
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Brian Brock
Depends On:
Blocks: 215581
  Show dependency treegraph
Reported: 2006-10-05 07:45 EDT by Mark McLoughlin
Modified: 2007-11-30 17:11 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-22 18:26:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
iscsi-x86_64-no_iommu_init.patch (1.02 KB, patch)
2006-11-14 13:43 EST, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2006-10-05 07:45:21 EDT
With iSCSI root on x86_64 DomU I was seeing an oops in
scsi_calculate_bounce_limit() where PCI_DMA_BUS_IS_PHYS() was called.
Issue is that dma_ops is NULL.

This changeset fixes it:

Comment 2 Mark McLoughlin 2006-10-05 09:00:21 EDT
Background is unless no_iommu_init() is called, dma_ops on x86_64 is NULL
causing the scsi subsystem to oops when trying to use iSCSI root.

The patch basically fixes a merge error. While porting the xen stuff to 2.6.28,
the iommu init stuff from x86/kernel/pci-dma.c was copied to
i386/kernel/pci-dma-xen.c and the pci_iommu_init() function appears to have been

Patch was worked out between cdub and myself and just brings us back in line
with upstream kernel.org. I'm running both my x86_64 dom0 and domU with it.
There doesn't appear to be any regressions.

What I'm not clear on is why the problem didn't result in more oops than just
with iSCSI.
Comment 3 Mark McLoughlin 2006-11-14 13:34:53 EST
*** Bug 215463 has been marked as a duplicate of this bug. ***
Comment 5 Mark McLoughlin 2006-11-14 13:43:39 EST
Created attachment 141168 [details]
Comment 6 Egon Kastelijn 2007-01-21 15:43:13 EST
I am having the same problem with kernel 2.6.19-1.2895.fc6xen with
iscsi-initiator-utils- on a FC6 XenU guest.
Comment 7 Egon Kastelijn 2007-02-17 14:31:46 EST
I updated my kernel to 2.6.19-1.2911.fc6xen using yum.
I also had to run "ethtool -K eth0 tx off" in my Xen guest to get rid of some
other TCP/IP crc problems I was having in combination with my nating Xen0.

After these two changes I am unable to reproduce the XenU kernel iscsi oopses I
had before.
(by the way: I did not explicitly use the above mentioned patch, but maybe it
has been integrated in the newer kernel I am using now)

So.. The problem has been solved for me!
Comment 8 Mark McLoughlin 2007-04-27 03:15:21 EDT
We still need this patch in rawhide
Comment 9 Jeremy Katz 2007-05-18 11:41:31 EDT
What's the ETA for getting this in?  We're in final freeze stages and trying to
get everything locked and ready to go for Fedora 7...
Comment 10 Jeremy Katz 2007-05-21 21:52:23 EDT
This doesn't look to be in AFAICT.

If this is going to get in for F7, it needs to get built by about noon Eastern
tomorrow as we're hoping to get an RC going tomorrow.
Comment 11 Eduardo Habkost 2007-05-22 08:53:26 EDT
F-7 build task submitted: 
Comment 12 Eduardo Habkost 2007-05-22 09:01:58 EDT
Fix was committed to 'devel' branch on CVS, also.

Note You need to log in before you can comment on or make changes to this bug.