Bug 2094319 - No video playback on Firefox 101 on some sites
Summary: No video playback on Firefox 101 on some sites
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-06-07 11:35 UTC by Gurenko Alex
Modified: 2022-06-17 01:19 UTC (History)
11 users (show)

Fixed In Version: firefox-101.0.1-1.fc37 firefox-101.0.1-4.fc36 firefox-101.0.1-5.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-10 03:43:13 UTC
Type: Bug


Attachments (Terms of Use)
Firefox message (5.24 KB, image/png)
2022-06-07 11:35 UTC, Gurenko Alex
no flags Details
about:config (39.96 KB, image/png)
2022-06-07 11:35 UTC, Gurenko Alex
no flags Details
Twitter error (10.67 KB, image/png)
2022-06-07 11:36 UTC, Gurenko Alex
no flags Details
Odysee (31.69 KB, image/png)
2022-06-07 11:36 UTC, Gurenko Alex
no flags Details

Description Gurenko Alex 2022-06-07 11:35:17 UTC
Created attachment 1887508 [details]
Firefox message

Description of problem: odysee, embedded video on twitter and some other web-sites cannot be played. 


Version-Release number of selected component (if applicable):

 - firefox-101.0-1.fc36.x86_64
 - mozilla-openh264-2.2.0-1.fc36.x86_64


How reproducible: 100%


Steps to Reproduce:
1. Update firefox from 100 to 101
2. Open odysee.com/twitter.com for example
3. Try to play video/embedded video

Actual results:

Video cannot be played. Respective message is shown on twitter and infinite loading animation is displayed on odysee. Also firefox is showing a message for missing codec.

I've made sure all the suggestions from https://bodhi.fedoraproject.org/updates/FEDORA-2022-080ea50338#comment-2554974 are correct, but still this isn't working for me. YouTube playback is unaffected.
Expected results:

Video is played just it was on Firefox 100. 

Additional info:
Downgrade to firefox 100 instantly restores the functionality.

This is a problem on my desktop with AMDGPU (RX 6700XT) if it matters.

Comment 1 Gurenko Alex 2022-06-07 11:35:51 UTC
Created attachment 1887509 [details]
about:config

Comment 2 Gurenko Alex 2022-06-07 11:36:09 UTC
Created attachment 1887510 [details]
Twitter error

Comment 3 Gurenko Alex 2022-06-07 11:36:29 UTC
Created attachment 1887511 [details]
Odysee

Comment 4 Martin Stransky 2022-06-07 11:43:58 UTC
Please attach content of about:plugins and try to remove ffmpeg-free packages if they're installed.

Comment 5 Gurenko Alex 2022-06-07 12:14:13 UTC
(In reply to Martin Stransky from comment #4)
> Please attach content of about:plugins and try to remove ffmpeg-free
> packages if they're installed.

Here is a content of about:plugins:

OpenH264 Video Codec provided by Cisco Systems, Inc.

    File: system-installed
    Path: /home/agurenko/.mozilla/firefox/72w8miv5.default-release/gmp-gmpopenh264/system-installed
    Version: system-installed
    This plugin is automatically installed by Mozilla to comply with the WebRTC specification and to enable WebRTC calls with devices that require the H.264 video codec. Visit https://www.openh264.org/ to view the codec source code and learn more about the implementation.

Widevine Content Decryption Module provided by Google Inc.

    File: 4.10.2449.0
    Path: /home/agurenko/.mozilla/firefox/72w8miv5.default-release/gmp-widevinecdm/4.10.2449.0
    Version: 4.10.2449.0
    State: Enabled
    This plugin enables playback of encrypted media in compliance with the Encrypted Media Extensions specification. Encrypted media is typically used by sites to protect against copying of premium media content. Visit https://www.w3.org/TR/encrypted-media/ for more information on Encrypted Media Extensions.

$ rpm -q ffmpeg-free                                                                         0  1
package ffmpeg-free is not installed

Comment 6 Martin Stransky 2022-06-07 15:56:27 UTC
What do you get from

rpm -qa ffmpeg\*

terminal command?

Comment 7 Gurenko Alex 2022-06-07 16:28:33 UTC
(In reply to Martin Stransky from comment #6)
> What do you get from
> 
> rpm -qa ffmpeg\*
> 
> terminal command?

I get no output.

Comment 8 Gurenko Alex 2022-06-07 22:49:00 UTC
Hm, just installed VLC which brought a lot of dependencies including ffmpeg-libs-5.0.1-3.fc36.x86_64 and now it's working. Is that a change from FF100 -> FF101 that it relies on a system libs instead of built-ins? If so, should FF package bring ffmpeg-libs as a dependency?

Comment 9 Martin Stransky 2022-06-08 06:15:23 UTC
(In reply to Gurenko Alex from comment #8)
> Hm, just installed VLC which brought a lot of dependencies including
> ffmpeg-libs-5.0.1-3.fc36.x86_64 and now it's working. Is that a change from
> FF100 -> FF101 that it relies on a system libs instead of built-ins? If so,
> should FF package bring ffmpeg-libs as a dependency?

We can't install ffmpeg-libs by default as it contains patented things and it's provided by rpmfusion.org project.
So it looks like your system was correctly installed and you seen just openh264 bugs there.
Firefox uses ffmpeg-libs when they're installed since gstreamer support removal years ago, there's no change on Firefox side there.

Comment 10 Gurenko Alex 2022-06-08 08:40:47 UTC
(In reply to Martin Stransky from comment #9)
> (In reply to Gurenko Alex from comment #8)
> > Hm, just installed VLC which brought a lot of dependencies including
> > ffmpeg-libs-5.0.1-3.fc36.x86_64 and now it's working. Is that a change from
> > FF100 -> FF101 that it relies on a system libs instead of built-ins? If so,
> > should FF package bring ffmpeg-libs as a dependency?
> 
> We can't install ffmpeg-libs by default as it contains patented things and
> it's provided by rpmfusion.org project.
> So it looks like your system was correctly installed and you seen just
> openh264 bugs there.
> Firefox uses ffmpeg-libs when they're installed since gstreamer support
> removal years ago, there's no change on Firefox side there.

Right, I forgot it came from rpmfusion. So the bug is still on the openh264 side? Should I move this issue/discussion to Mozilla's bugzilla?

Comment 11 Martin Stransky 2022-06-08 09:06:30 UTC
(In reply to Gurenko Alex from comment #10)
> (In reply to Martin Stransky from comment #9)
> > (In reply to Gurenko Alex from comment #8)
> > > Hm, just installed VLC which brought a lot of dependencies including
> > > ffmpeg-libs-5.0.1-3.fc36.x86_64 and now it's working. Is that a change from
> > > FF100 -> FF101 that it relies on a system libs instead of built-ins? If so,
> > > should FF package bring ffmpeg-libs as a dependency?
> > 
> > We can't install ffmpeg-libs by default as it contains patented things and
> > it's provided by rpmfusion.org project.
> > So it looks like your system was correctly installed and you seen just
> > openh264 bugs there.
> > Firefox uses ffmpeg-libs when they're installed since gstreamer support
> > removal years ago, there's no change on Firefox side there.
> 
> Right, I forgot it came from rpmfusion. So the bug is still on the openh264
> side? Should I move this issue/discussion to Mozilla's bugzilla?

openh264 is provided by Cisco so you can file a bug here: https://github.com/cisco/openh264/issues

Comment 12 Chris Murphy 2022-06-09 14:20:26 UTC
Updating to firefox-101.0-1.fc36.x86_64 broke video on some sites, and downgrading back to firefox-100.0-2.fc36.x86_64 fixes it. I don't have anything installed from rpm fusion.

$ rpm -qa ffmpeg\*
(no results)

Maybe I should file a separate bug as this is a pretty clear regression from a recent clean install without any non-Fedora packages installed.

Comment 14 Fedora Update System 2022-06-10 03:39:48 UTC
FEDORA-2022-9277f357d1 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-9277f357d1

Comment 15 Fedora Update System 2022-06-10 03:43:13 UTC
FEDORA-2022-9277f357d1 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2022-06-10 06:24:38 UTC
FEDORA-2022-950e0f78c7 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-950e0f78c7

Comment 17 Fedora Update System 2022-06-10 06:24:39 UTC
FEDORA-2022-0e2ff84e1e has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-0e2ff84e1e

Comment 18 Fedora Update System 2022-06-11 01:14:37 UTC
FEDORA-2022-0e2ff84e1e has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-0e2ff84e1e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-0e2ff84e1e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2022-06-15 01:10:58 UTC
FEDORA-2022-950e0f78c7 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-950e0f78c7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-950e0f78c7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2022-06-15 01:15:18 UTC
FEDORA-2022-0e2ff84e1e has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-0e2ff84e1e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-0e2ff84e1e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2022-06-16 01:20:46 UTC
FEDORA-2022-950e0f78c7 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2022-06-17 01:19:16 UTC
FEDORA-2022-d1c8a76563 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.