This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 209437 - GNU tar update to 1.15.1-15.FC5 breaks existing amanda installations
GNU tar update to 1.15.1-15.FC5 breaks existing amanda installations
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 08:27 EDT by Jonathan Larmour
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 12:55:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Larmour 2006-10-05 08:27:38 EDT
Description of problem:

I was the original reporter of bug 206979. This was converted to an RHEL bug
which I don't have perms to change, and 207115 was cloned from it for FC5, which
I didn't create and so I can't reopen. Hence this new bug which is just a
continuation as the problem is not resolved. It may also apply to RHEL5.

The update to tar-1.15.1-15.FC5 has not fixed matters, just changed them. The
following was recorded in my amanda run:

/-- dargo      /usr lev 4 FAILED [/bin/tar returned 2]
sendbackup: start [dargo:/usr level 4]
sendbackup: info BACKUP=/bin/tar
sendbackup: info RECOVER_CMD=/bin/tar -f... -
sendbackup: info end
? gtar: /var/lib/amanda/gnutar-lists/dargo_usr_4.new:1: Invalid time stamp
| Total bytes written: 1307985920 (1.3GiB, 2.3MiB/s)
? gtar: Error exit delayed from previous errors
sendbackup: error [/bin/tar returned 2]
\--------

Taking /boot as a simpler example, analysis of the amanda logs showed that
amanda caused this with this (not very special for amanda) invocation:
/bin/tar --create --file /dev/null --directory /boot --one-file-system
--listed-incremental /var/lib/amanda/gnutar-lists/dargo_boot_1.new --sparse
--ignore-failed-read --totals --exclude-from
/var/log/amanda/sendsize._boot.20061005020036000.exclude .


/var/lib/amanda/gnutar-lists/dargo_boot_1.new starts off as a copy of the
existing incremental backup, so I can reproduce this problem by first doing:
 cp /var/lib/amanda/gnutar-lists/dargo_boot_1
/var/lib/amanda/gnutar-lists/dargo_boot_1.new
and then the above tar command which indeed gives the error output.

This is the entirety of /var/lib/amanda/gnutar-lists/dargo_boot_1:
GNU tar-1.15.90-1
1159839407 953396000
1149277979 0 2304 11 ./lost+found
1158383967 0 2304 8033 ./grub
1158383967 0 2304 8033 ./grub/
1158383965 0 2304 2 ./
1149277979 0 2304 11 ./lost+found/

and this is the entirety of /var/lib/amanda/gnutar-lists/dargo_boot_1.new after
the above tar command has rewritten it:
1160050480
2304 11 ./lost+found
2304 8033 ./grub

So there seems to be another incompatible file format change.

Version-Release number of selected component (if applicable):

tar-1.15.1-15.FC5
Comment 1 Peter Vrabec 2006-10-05 11:30:03 EDT
problem is that each tar release(1.15.1, 1.15.90, 1.15.91) use different state file. Amanda is 
not adjusted to work with 1.15.91 and incremental backup in 1.15.90 works wrong, therefore we 
have decided to downgrade tar to 1.15.1. Unfortunately 1.15.1 can't read state files from 
1.15.90.

This problem doesn't affect RHEL-5, because RHEL-5 is not released, so there aren't any 
1.15.90  state files.

I suggest to  force amanda to do new tar backup of level 0, it should recreate the state files, 
and then things will work.

Comment 2 Jonathan Larmour 2006-10-05 12:55:38 EDT
OK. I guess you'll have to worry about this for RHEL-6 then :-).

I'll force level 0s and get on with life. So I'm marking as WONTFIX.

Thanks,

Jifl

Note You need to log in before you can comment on or make changes to this bug.