Bug 209442 - zip does not honor umask setting when creating archives.
zip does not honor umask setting when creating archives.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: zip (Show other bugs)
4.4
All Linux
medium Severity high
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
: 201640 (view as bug list)
Depends On:
Blocks: 371041
  Show dependency treegraph
 
Reported: 2006-10-05 09:03 EDT by Gunther Schlegel
Modified: 2007-11-21 07:08 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-1040
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 07:08:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (346 bytes, patch)
2006-10-11 04:35 EDT, Ivana Varekova
no flags Details | Diff

  None (edit)
Description Gunther Schlegel 2006-10-05 09:03:54 EDT
Description of problem: when creating an archive with zip, zip does not honor
the umask. This behaviour is different from RHEL 3.8


Version-Release number of selected component (if applicable):
zip-2.3-27

How reproducible:
Create a new archive, check access permissions.

Steps to Reproduce:
1. zip test /some/file
2. ls -l test.zip
3. -> The writing right for the group is missing.
  
Actual results:
RHEL 4:
[admin@leibniz tmp]$ umask
0007
[admin@leibniz tmp]$ zip test /etc/services
  adding: etc/services (deflated 65%)
[admin@leibniz tmp]$ ls -l test.zip 
-rw-r-----  1 admin admin 7163 Oct  5 15:01 test.zip


Expected results:
RHEL 3:
[admin@hilbert tmp]$ umask
0007
[admin@hilbert tmp]$ zip test /etc/services 
  adding: etc/services (deflated 65%)
[admin@hilbert tmp]$ ls -l test.zip 
-rw-rw----    1 admin    admin        7134 Oct  5 15:02 test.zip


Additional info:
Comment 1 Ivana Varekova 2006-10-11 04:35:45 EDT
Created attachment 138226 [details]
proposed patch
Comment 2 Ivana Varekova 2006-10-11 04:56:47 EDT
*** Bug 201640 has been marked as a duplicate of this bug. ***
Comment 5 Ivana Varekova 2007-10-26 05:20:46 EDT
Putting on the proposed list.
Comment 10 errata-xmlrpc 2007-11-21 07:08:07 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1040.html

Note You need to log in before you can comment on or make changes to this bug.