Bug 209487 - mounting (ext3) filesystems twice
mounting (ext3) filesystems twice
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 12:03 EDT by Florian La Roche
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 15:43:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2006-10-05 12:03:43 EDT
Description of problem:

With a current FC-development machine, I can mount a ext3 filesystem
read-write twice without getting any warning or error message from the
kernel:

    mount /dev/sda1 /data1
    mount /dev/sda1 /data2


Is this check up to the (l)user requesting this or should the kernel
return EBUSY for this case?

regards,

Florian La Roche





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Karel Zak 2006-10-05 12:13:41 EDT
Same with 2.6.17-1.2187_FC5
Comment 2 Eric Sandeen 2006-10-05 15:43:09 EDT
So does 2.6.9...

[root@aluminium ~]# mount /dev/hda7 /mnt/test
[root@aluminium ~]# mount /dev/hda7 /mnt/test2

[root@aluminium ~]# uname -a
Linux aluminium.msp.redhat.com 2.6.9-42.EL #1 Wed Jul 12 23:16:43 EDT 2006 i686
i686 i386 GNU/Linux

[root@aluminium ~]# mount | grep hda7
/dev/hda7 on /mnt/test type ext3 (rw)
/dev/hda7 on /mnt/test2 type ext3 (rw)

And it can be done with any other fileystem too.

but there's nothing wrong with that... why do you think this is a bug?
Comment 3 Karel Zak 2006-10-05 16:38:59 EDT
Sorry, you're right. I've to refresh my old knowledge of linux. It's possible
since 2.4. The mount(2) man page:

 Since Linux 2.4 a single filesystem can be visible at  multiple  mount  points,
 and multiple mounts can be stacked on the same mount point.

Note You need to log in before you can comment on or make changes to this bug.