Bug 20950 - rpm stops with 'memory alloc returned NULL'
Summary: rpm stops with 'memory alloc returned NULL'
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-16 12:46 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-16 12:46:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-16 12:46:12 UTC
When trying to install, upgrade or do other rpm-related things, rpm stops
with the message:

memory alloc (2581680408 bytes) returned NULL.

The actual number of bytes is sometimes different:

[root@mordor roel]# helix-update
Distribution: Red Hat Linux 7.0
memory alloc (1420823072 bytes) returned NULL.

I have tried rebuilding the db, but this also fails with the same error.

Comment 1 Jeff Johnson 2000-12-17 01:22:19 UTC
For unknown reasons, rpm is requesting very large malloc's. Rather than
returning a NULL pointer and segfaulting, rpm simply exits with an error
message.

This is usually caused by asking rpm to install a corrupted package, but without
more details about what operation you are trying to perform, I cannot tell more.

Please reopen with more specific details.


Note You need to log in before you can comment on or make changes to this bug.